Announcement

Collapse

Welcome to the New Server!

Apolyton.net is now pointing to the new server. Please let us know if you spot any oddities or have any suggestions for what to add to the site!
See more
See less

UTILITY: Civ3MultiTool - A second thread for the Program ;)

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • a little wish for savegame editor...

    how about making a little larger window (like the one where u chose attributes of unit in civ3edit) for unit list? So u can chose many units at a time... cuz when u play on a huge map, it turns veeeeeeeery slow because of a huge ammount of units so that's be nice to have a way to delete some of them, sometimes
    And that thing where u chose known advanses for civilizations, it doesn't work, when u choose any option in drop menu (except barbarian) the rpogram outputs an error and shuts down.

    Comment


    • Originally posted by FlyinFish
      "zip a save"?
      I am quite fresh...in both English and programing.
      what files do you need?
      The saves are files in the Civ2 subdirectory 'Saves'

      They are the files you load with the editor. So what I need is basicly the file you try to edit.

      And you to make it smaller you should compress it. Then send it to [email protected]
      Creator of the Civ3MultiTool

      Comment


      • Re: V.95

        Originally posted by lorddread
        Gramphos,

        Where can I find ver .95? I have .93 and it (SGE) doesn't work with 1.29 files...
        First post in the thread.


        Also, any advise on moving stacks?

        Not yet. I've been working on it, but then all bugs showed up...
        Creator of the Civ3MultiTool

        Comment


        • I've sent you my saves Gramphos.
          But you've said the problem may be caused by VB.And I quite agree to this...
          Damn Microsoft :-(
          Anyway,thanks for your work Gramphos.

          Comment


          • Well, the problem is a VB error, but it's probably because of something I doesn't count for in your saves.
            Creator of the Civ3MultiTool

            Comment


            • Re: a little wish for savegame editor...

              Originally posted by Copper
              And that thing where u chose known advanses for civilizations, it doesn't work, when u choose any option in drop menu (except barbarian) the rpogram outputs an error and shuts down.
              Savefile and gameversion.
              Creator of the Civ3MultiTool

              Comment


              • I'm right now correcting some old bugs which has been in for a while, and improving some parts of the tool. I hope to be able to get a more stable version out next week. (And hopefully IK can finish a feature which has been on the todo list for a while, and I finally has the time to work on a little more.)
                Creator of the Civ3MultiTool

                Comment


                • !!! PLEASE SOMEBODY HELP ME !!!
                  Whenever I try to edit a SaveGame File I get this message on my screen "Stop Statement Encountered" then the SGE exits.

                  Would ANYone have the answer to that?
                  Eu nunca tenho algo criativo para escrever aqui...

                  See this? You've just wasted 5 precious seconds of your life reading it.

                  Comment


                  • Never seen that one before.
                    Creator of the Civ3MultiTool

                    Comment


                    • 2 different errors

                      Hi all,

                      Has anyone else had either of these probles?

                      1. When adding units using the SGE, I get an illegal error and the SGE shuts down.

                      2. When exporting a map to the editor, it never loads. I get an hour glass and the a illegal error and it shuts down. However it works with a previously created but never played bic file.


                      Thanks
                      KATN

                      Comment


                      • Hi, Gramphos.
                        How do I send here images? I want to show you the message I get when I try to use SGE.

                        And I said it crashed for every savegame. It doesn't. It just crashes when I try to edit one specific savegame I have.
                        Eu nunca tenho algo criativo para escrever aqui...

                        See this? You've just wasted 5 precious seconds of your life reading it.

                        Comment


                        • Run Time Error '9'

                          I get the following error whenever I access the map stats on C3MT

                          Run Time Error '9'
                          Subscript Out of Range

                          Any Ideas?

                          Comment


                          • Hi. It's me again.
                            I uninstalled Civ3 and C3MT then reinstalled, but I still get "stop statement encountered" when trying to edit one particular savegame with SGE.

                            Got any clues?


                            P.S.: I forgot to thank Gramphos for this sw. It's not perfect. ROCKz, though!!!! How did you get all those variables addresses? You're good, man.
                            Eu nunca tenho algo criativo para escrever aqui...

                            See this? You've just wasted 5 precious seconds of your life reading it.

                            Comment


                            • Re: Run Time Error '9'

                              Originally posted by Unconquered
                              I get the following error whenever I access the map stats on C3MT

                              Run Time Error '9'
                              Subscript Out of Range

                              Any Ideas?
                              Yes, actually I have: You have an old language file.
                              Creator of the Civ3MultiTool

                              Comment


                              • Originally posted by SkalTur
                                Hi, Gramphos.
                                How do I send here images? I want to show you the message I get when I try to use SGE.

                                And I said it crashed for every savegame. It doesn't. It just crashes when I try to edit one specific savegame I have.
                                On the full reply screen there is an Attach file field.

                                the width must be max 200px and the file must not be bigger then 500kB.
                                Creator of the Civ3MultiTool

                                Comment

                                Working...
                                X