Announcement

Collapse

Welcome to the New Server!

Apolyton.net is now pointing to the new server. Please let us know if you spot any oddities or have any suggestions for what to add to the site!
See more
See less

Possible Fixes for "Failed to Initialize Renderer" Startup Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guys, I may need some help.

    I tried to remove the ATI driver with the ATI uninstaller thing from the website. That was a success.

    Then I restarted. After the restart, my screen went to a 640 x 480 resolution instead of my 800 x 600 resolution. I reverted my screen to my original setting. Success.

    Then I tried installing the new Catalyst 5.10 driver that this thread was talking about. However, this is where I ecounter the problem. The installation process starts up just fine, then when the actual installation process starts, it says "New Hardware Found" and says Video Controller (VGA Compatible).

    The installation process aborts because it can't find video controller or the VGA thing. What do I do?


    Also, for some reason, my computer is a lot more sluggish now. Even websites like this one and scrolling down the website is very sluggish. Why is this?

    I hope I didn't destroy my computer. My computer is a laptop with an Mobility Radeon 9000, 3 GHZ Intel Pentium 4 processor, and 1 GB RAM.
    Geniuses are ordinary people bestowed with the gift to see beyond common everyday perceptions.

    Comment


    • Well, here's my horror story.
      Specs:
      Athlon 2800+, Abit KT7-MAX2, 1 GB ram, Chaintech GF4 4200 Ti, SB Live! Gamer, DX 9c installed fron the game. XP pro SP1 (all of which more than meets the minimum specs for the game)

      first time I got it running with little - no problem, except for the video files. All of the video playback have a stuttering sound problem - the splash screens, the intro movie (Go Leonard!) and all of the various wonder movies. I played through the tutorial all the way (thanks Sid!) with a little annoying bit, slow response time. I turned the graphics all the way down and started it up again. Played only marginally better.
      after about an hour or so of gameplay, it crashed hard. I mean BSOD hard - the bluescreen of death was telling me to check my video drivers, which weren't the most recent, so I downloaded the newest ones from Nvidia's website (81.85 I think) and got it up and running again.
      this time i was able to play for a couple hours before it crashed on me. not to a BSOD, just boom, you're not playing anymore and here's your nice desktop.

      Today when I started it up I got to play for an hour before it crashed again as before, but now it won't go back into the game (gives me the infamous render error) without a complete system re-boot.

      and for a nice bonus, when I go into display properties after the most recent crash?
      my "settings" tab appears to think that I'm running at 640x480 resolution with 4 bit color!!!!!

      Firaxis, I appreciate the civ franchise - I've been playing for ever like most people here and love the games in general, but you should NEVER fall to the pressures of the Publisher and put out a product as buggy as this one appears to be.
      I patiently await a patch. Thanks.

      Chern

      Comment


      • Check how much free hard drive space you have once the game is installed. If you run too low and Windows tries to use more than you have available, it can cause all sorts of problems with crashing.

        Comment


        • 4GB. Civ is installed on drive D, my HD is partitioned into 4 blocks.

          Chern2

          Comment


          • Originally posted by Sovereign
            Then I tried installing the new Catalyst 5.10 driver that this thread was talking about. However, this is where I ecounter the problem. The installation process starts up just fine, then when the actual installation process starts, it says "New Hardware Found" and says Video Controller (VGA Compatible).

            The installation process aborts because it can't find video controller or the VGA thing. What do I do?
            Was there an error message that suggested it aborted "because it can't find video controller or the VGA thing"?

            So during the installation process, the "New Hardware Found" dialog came up; did you also get the "Windows is installing the software for your new hardware" dialog with the copy animation? and did that finish and return to the Catalyst installer?

            Comment


            • Chern, you need to upgrade to SP2 since it includes many fixes and also has a few changes. Do you have the .NET framework 1.1 installed with the updates for it as well?

              For everyone that doesn't know, it's impossible for a company to properly test on systems that havn't had their MS Windows updated to include the latest patches. For Windows XP, that means Service Pack 2, and the .NET framework 1.1 stuff is required for ATI Catalyst drivers with the Catalyst Control Center.

              Since it seems that ATI users have this problem, making sure that your copy of Windows is up to date is critical. To verify, in Internet Explorer, go to: http://windowsupdate.microsoft.com

              Follow the instructions and have it check for updates. Go with custom to see the list of updates and make sure you pick everything except the hardware updates. The hardware updates CAN in some cases cause Windows to have critical problems so I don't suggest you install them.

              After you do a set of updates, make sure to reboot if it tells you to, then go back to windowsupdate.microsoft.com and check again, and again, until there are no more updates. It's a complaint of mine that Microsoft doesn't replace versions of it's fixes that have bugs, so you have to install the first fix, then the fix for the fix, then the fix for the fix of the fix. But, eventually you will get them all installed, and that MAY help. Keep in mind that if you don't reboot when it tells you to, it may not have finished installing a patch, so the next update you try to install may fail.

              Comment


              • I don't use .net at all, and I've been dreading the update to SP2, there was so much bad press about it when it came out...I suppose now I have no choice.
                My video card isn't ATI though, its Nvidia.

                Chern

                Comment


                • updated to SP2. took about 3 reboots.
                  movies still stuttered on intro. don't have time to check gameplay tonight, maybe tomorrow.

                  Chern

                  Comment


                  • 9.0b to 9.0c

                    i have a problem when installing 9.0c, from the civ4 dvd (and from the microsoft)

                    when i try to install 9.0c, it accept and stuf, then instead of installing it (it waits a few sec, without progres bar progression) goes direct to installed window ( finished one )
                    then when i check version in dxdiag it still it 9.0b
                    even after restarting

                    i have started bouth installations a hundred times, and still the dxdiag tells me that i have 9.0b version (4.09.0000.0903)

                    the 9.0c on the civ4 cd places d3dx9_26.dll into c:\windows\system 32\

                    i have try with d3dx9_27.dll too, still getting "Failed to Initialize Renderer ..."

                    how can I "delete" 9.0b and install for sure 9.0c?

                    here's my dxdiag info

                    help pls, thanx
                    Attached Files
                    Last edited by stendec; November 3, 2005, 06:50.

                    Comment


                    • .NET framework is being used for applications now, so while I HATE that stuff too, it's required for the Catalyst Control Center and a few other things. As a result, even if you arn't running an ATI card, it's a good idea to install the piece of junk with the 4 patches that have come out for 1.1.

                      On the dx9 install, I would suggest checking what applications you have running. Antivirus software or other software designed to prevent spyware or registry changes could be blocking the install. Check the services(under administrative tools in control panel), and turn off the ones that arn't needed. Just some ideas here.

                      Comment


                      • hm, I have reinstalled Windows XP sp2 today, so all of the settings of CP/administrative tools/services are default, i have no AV on pc installed
                        i find myself not that advanced in pc use to change any of settings in services... did u mean on any particular?

                        Comment


                        • The key is to isolate potential sources of problems. You can choose to simply stop a service in most cases if you want to turn it off for a while, then start it again or restart Windows to turn everything back on.

                          Things like antivirus protection, spyware blockers, and other services. If you see Symantec or Norton next to a name, that's a Norton Antivirus service for example.

                          If you don't have wireless, you don't need the wireless zero configuration service. You don't need remote registry for this either. The remote connection manager is used by the Windows firewall so you need to leave that on.

                          RPC is needed by all sorts of things within Windows XP(unfortunately), so you need to keep it on. RPC is why the blaster worm was forcing Windows to restart all the time if any of you remember that one.

                          If you have an IPOD, you can turn off the service for that while trying to get things working.

                          DHCP is how IP addresses are automatically assigned by your ISP or broadband router, so you need to leave that on.

                          Some services are a part of a spyware/adware infection, so they can cause problems. Spyware is a topic of another post/thread so if you need advice, let me know.

                          Comment


                          • Originally posted by Trip
                            Yes, that appears to be correct.
                            Hi Trip,

                            I cannot more, I am becoming crazy...

                            I have proven it everything more than thousand times and it does not go to me. There is something can do before leaving the patch?

                            When we will have the patch?

                            I cannot wait for more.
                            El futuro pertenece a quienes creen en la belleza de sus sueños.
                            - Eleanor Roosevelt

                            Comment


                            • Gameplay didn't change appreciably. still stuttered on the movies, intros, etc.
                              slow responding graphics, and the tile improvement disappearing act happened about 4 times. (every other turn!) played maybe 8 turns of a previous game.
                              Still - mine isn't as bad as some people. I never had the problem with the leaders getting all rendered wrong.

                              Chern

                              Comment


                              • deinstall + new install worked for me

                                Having installed the ATI 5.1 drivers with no results I finally deinstalled CIV 4 completely and installed it anew. It works!

                                At least I do not get the "Failed to Initialize Renderer" message. But I still get a blue screen at least every hour or so. And when I say Blue Screen, I mean it, there is not the usual unintelligible yada yada, the screen is absolutely blue. I think I wait at least two patches until I try CIV 4 again in earnest.

                                Comment

                                Working...
                                X