Announcement

Collapse
No announcement yet.

Possible Fixes for "Failed to Initialize Renderer" Startup Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Possible Fixes for "Failed to Initialize Renderer" Startup Error

    Firaxis is currently looking into the startup issues people are experiencing.

    There appear to be two seperate issues which lead to the "Failed to Initialize Renderer" bug.

    -------------------------------

    1) When installing Civ 4 you MUST install the version of DirectX 9 that shows up. If you get a window asking you to upgrade you NEED to update to the new version. Aside from Civ 4 this version is only available through the DirectX Development kit and does not come with other games or with the user DirectX you find through Microsoft.

    -------------------------------

    If you still get the error...

    2) People who are receiving a failure to initialize error on startup that own ATI cards should do the following. This has worked on every test case where this problem was experienced.

    1. Go to add/remove programs and uninstall the listing titled ‘ATI Graphics Driver’
    2. Once uninstalled they need to download the latest version of the Windows Catalyst Driver – 5.10

    Windows XP & Windows 2000:
    https://support.ati.com/ics/support/...ge&folderID=27

    3. REBOOT
    4. Retry launching the game

    -------------------------------

    If you still get the error...

    See this thread:

    http://www.apolyton.net/forums/showt...hreadid=140859
    Last edited by Jon Shafer; October 27, 2005, 18:12.

  • #2
    I've done everything I can to deinstall the old drivers; the problem doesn't go away. Does anyone have a quickie explanation as to how to ensure my drivers are fully deinstalled?

    Comment


    • #3
      See first post.
      Last edited by Jon Shafer; October 26, 2005, 17:52.

      Comment


      • #4
        No dice. Uninstalled ATI Driver and Control Panel. Ran Driver Cleaner with ATI filter to get the old junk out. Reinstalled Cat 5.10. Failed to initialize renderer.

        Comment


        • #5
          Same here. I followed these exact steps on three different computers with three different ATI cards, and no effect.

          Comment


          • #6
            Additionally, the DirectX version included with Civ 4 should be installed as there are additional updates besides DirectX 9c included.

            Comment


            • #7
              Try the ATI UN-installer.

              http://support.ati.com/ics/support/D...737&deptID=894
              "Build Ports when possible. A port gives you extra resources, as well as an extra tile for a unit to stand on." - Infogrames

              Comment


              • #8
                Originally posted by Amniotic
                No dice. Uninstalled ATI Driver and Control Panel. Ran Driver Cleaner with ATI filter to get the old junk out. Reinstalled Cat 5.10. Failed to initialize renderer.
                Hrm, I'll wait before I uninstall my drivers then hehe...with my luck I'll jack up my other SW.

                Comment


                • #9
                  Again, make sure you install the DirectX included on the Civ4 CD.
                  Solver, WePlayCiv Co-Administrator
                  Contact: solver-at-weplayciv-dot-com
                  I can kill you whenever I please... but not today. - The Cigarette Smoking Man

                  Comment


                  • #10
                    Originally posted by Solver
                    Again, make sure you install the DirectX included on the Civ4 CD.
                    Solver, when you install Civ4 and it runs its auto-check for DX, it automatically installs the DX updates on the CD, right?

                    Comment


                    • #11
                      When installing Civ 4 if you don't have the most recent version of DirectX 9 then a window will come up asking you to install it. If you do not you will not be able to run the game. This version of DirectX is available basically no where else.

                      Comment


                      • #12
                        Every direction followed to the letter. "Failed to initialize renderer"

                        Comment


                        • #13
                          If you already have DirectX 9.0c installed, then AFAICT, the DX installer on the Civ CD does nothing. At least it certainly did not appear to actually select and install anything on any of the four installs I have done today (over 2 machines).

                          I also cannot tell how to uninstall DirectX from my system (thinking that wiping it out and then manually installing from the Civ CD would work). Any enlightenment on that score?

                          Comment


                          • #14
                            I wouldn't know, I don't have a copy of the retail version. It's my understanding that the setup program asks you about installing DX, and you need to do that.
                            Solver, WePlayCiv Co-Administrator
                            Contact: solver-at-weplayciv-dot-com
                            I can kill you whenever I please... but not today. - The Cigarette Smoking Man

                            Comment


                            • #15
                              Can a mod please rename this thread to:

                              Possible Fixes for "Failed to Initialize Renderer" Startup Error

                              Edit: Thanks

                              Comment

                              Working...
                              X