No announcement yet.

Bug Reports - put them here

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Reports - put them here

    only post specifc reports. reply to something only if to correct , not to start a discussion
    Co-Founder, Apolyton Civilization Site
    Co-Owner/Webmaster, | CTO, Apogee Information Systems my non-mobile non-photo news & articles blog

  • #2
    -- B.C. (money) slider won't go in increments of 1 at higher levels of money! You *can* type in the number, but this is less than optimal.

    -- [not a bug, I understand, but important]: AI's declaration of war isn't clear!!! It will make threats but never (hardly ever?) actually say "We are at war." So you have to click to another screen after each threat to see if he actually declared war.

    -- Starbase text that explains the improvements get truncated.

    -- [not a bug, I hear, but bad enough to be called one! ] The option to offer an Alliance does not show up unless you are in 'Close' relationship. This might make sense at first, but it looks like a bug otherwise! If I have the tech to offer an alliance, let me offer it!!! Just have the AI refuse. This one really hurt me in my current game.

    --Upon reload, your cultural points need a few turns to get back where they should be. Same for number of turns for a tech to finish.
    Last edited by yin26; April 1, 2003, 15:16.
    I've been on these boards for a long time and I still don't know what to think when it comes to you -- FrantzX, December 21, 2001

    "Yin": Your friendly, neighborhood negative cosmic force.


    • #3
      - there seem to be some issues with the espionage spending. you increase spending on one civ and it could also be increased on another. stuff like that....
      Co-Founder, Apolyton Civilization Site
      Co-Owner/Webmaster, | CTO, Apogee Information Systems my non-mobile non-photo news & articles blog


      • #4
        If GalCiv locks up after playing the movies, rename the MOVIES subdirectory to something else, which will cause the game to skip the movies altogether. Then you can play it.

        (I got this far after searching for "crash" on GalCiv's forums, since a search for "lock up" returned no results. One of the beta testers ran into a similar problem back in January, and the proposed workaround was to rename intro.bik and sf_intro.bik. I did that, and it worked, in that I was able to get to the main menu and select settings. But after that, there's another movie before the game starts, which caused the same problem, so I just renamed the whole MOVIES directory, and then everything was OK.)

        (System: Athlon 650, 256 MB, Win98SE, TNT2 video card. Same problem before and after the 1.01 update. I even tried reducing the video driver acceleration slider by one notch under the Win98 Control Panel, to no avail.)

        (Exact symptom: start the program, wait a bit, the screen switches to low resolution (you can tell by the size of the mouse pointer), a movie plays, the screen switches to a higher resolution and is cleared to black, and then... nothing. You can move the mouse pointer, but the entire computer is otherwise dead in the water, and you must hit the Reset button. Ctrl-Alt-Del doesn't even work.)


        • #5
          I can continue to build a wonder on a planet after another planet I own has built it. As a result I had two economic capitals. Next time I will make sure all planets I have are building it at the same time..hehe. But seriously, This bug has to be fixed.
          Citizen of the Apolyton team in the ISDG
          Currently known as Senor Rubris in the PTW DG team


          • #6
            On the new patch I noticed that I can't demand starships, starbases, or some techs for a peace treaty. I can't trade for starships either.


            • #7
              I can't progress past the third month (March) The procedure for "next turn" is somehow broken. I have tryed this with and without the patches and multiple times, it is happening in every game. I can continue to move my ships on autopilot during these repated "Marchs" but the AI never moves, and the production on my planets never progresses, nor does my research. Anyone else have this problem? I'm dying here.

              1) The crappy metaspam is an affront to the true manner of the artform. - Dauphin
              That's like trying to overninja a ninja when you aren't a mammal. CAN'T BE DONE. - Kassi on doublecrossing Ljube-ljcvetko
              Check out the ALL NEW Galactic Overlord Website for v2.0 and the Napoleonic Overlord Website or even the Galactic Captians Website Thanks Geocities!
              Taht 'ventisular link be woo to clyck.


              • #8
                This is from version 1.03.054:

                If you have a group of ships bunched together to move as a fleet, you do not get the speed bonuses from your starbase improvements. I have a couple of corridors I'm using to shuttle warships and constructors, and each sector has 2 starbases, each with the inverse tractor beam and stellar wake.

                Apparently, when you "fleet" the ships, the AI takes into account the lowest speed, as it should, but ignores all external bonuses from starbases. The two fleets where this happened were one of four constructors and one of three, and I grouped them to save time moving them. Each normally has 5 moves, individually they have 9 moves once in my corridors, but as a fleet, they're stuck in 5 move mode until I separate them. Then next turn, they pick up the regular bonus.

                WoA: I haven't had anything similar. Curious, though, are you using the download, or CD version of the game? I would guess it's some file corruption problem.
                When all else fails, blame brown people. | Hire a teen, while they still know it all. | Trump-Palin 2016. "You're fired." "I quit."


                • #9
                  load crash

                  after days of successful loading, suddenly my 1.03A.057 game always crash to desktop during loading. Same for the 2 auto-saves. arrgh, perhaps the stand-alone 1.03 will fix this...well I had one game impossible to submit, and now this one impossible to continue ....I begin to lose faith...reported to the official forum.
                  The art of mastering:"la Maîtrise des caprices du subconscient avant tout".


                  • #10
                    - Even though morale is averaged at 87%, when I have an election, the game crashes, which my Norton catches, and then proceeds to tell me I have 0% of the votes.

                    - The stats section does not recognize the points I put towards economics when making my civilization, just the party points (I am federalists)

                    - After the UP issue giving transports an attack value for five years, they are unable to attack ships in orbit of planets, and then still need an escort!


                    • #11
                      Minor item: when I click on diplomacy for minor civs, the picture of major civs shows up in the screen at the lower left. The only way to clear it is to scroll forward, then the default minor civs show up.


                      • #12
                        I'm using the latest patch that i know of (1.03 i think) and every time there is an election (republican gov't...i've not gotten far enough into the game since the patch update to get to any other gov't.) it crashes to the desk as soon as i hit the next button. this only happened after i did the patch update. i thought this may have been a bad install on my part but i've now uninstalled and reinstalled the game 3 times. i just saw this reported on the official site so i'm glad to know i'm not the only one with this problem.


                        • #13
                          Lost SFX but kept music

                          I got a bit frustrated when I discovered that I lost the special effects sounds for the game (but kept the music) soon after running it after a cold reboot.

                          SOLUTION: I created a shortcut from galciv.exe and use that instead of the given gcmenu.exe and now it runs with all the sounds.

                          Anyone else discover this?
                          Avoid COLONY RUSH on Galactic Civlizations II (both DL & DA) with my Slow Start Mod.
                          Finding Civ 4: Colonization too easy? Try my Ten Colonies challenge.


                          • #14
                            My sound will disappear after playing for a while but I haven't downloaded a patch for a few weeks so I don't know that it's been fixed.


                            • #15
                              Typo: "There is nothing the enemy dreads more than a dreadnaught" (dreadnought)

                              Disappearing improvements: If you hurry build an improvement and then look at "details" in the planet display or switch projects, then the improvement disappers from your list of options and never reappears. Nor is it listed in the details.

                              Things that could use attention:

                              Repair: Too slow, I think. Even with decent repair skill and a starbase repair bay, the crews of your ships don't repair more than a couple of points of damage a month. This game does not need to be more of an attrition fest. Additionally this contributes to problem 2:

                              Experience rankings: My USS Hero, the oldest ship in the fleet, pride of Earth, destroyer of starbases, defeater of Overlords, veteran of countless battles ------- experience rating 1, Neophyte. What exactly do you have to do to reach 2? Survive the entire game? I don't even know what level 2 is called, to be honest. My ships never live that long. There is not much point in having an experience system in the game if it is never used and doesn't do anything.


                              1930's economics: The only real response to the "Galactic Recession" is to raise taxes and drastically cut governmental expenditures. This, ahem, does not fully comport with current beliefs or practice.
                              Last edited by Vanguard; May 28, 2003, 13:27.