Announcement

Collapse
No announcement yet.

Compiled with MS VS 2017 and Windows SDK 10

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Compiled with MS VS 2017 and Windows SDK 10

    Somehow I managed to build CtP2 (from trunk) with modern toolset. What works now:
    0) It starts
    1) Initial screen
    2) Sprite test in debug build - had to fix a small bug
    3) Settings
    4) Credits
    5) New game configuration
    6) Scenario editor
    What does not work:
    1) New game - progress bar get filled up to about 80% and then all stucks
    3) Load game - stucks after button click
    Can anybody confirm that trunk works?
    Can anybody help me?

  • #2
    OK. I did some refactoring (replaced shitload of raw pointers by smart pointers, but ****ton still there, DInput8, added paths to all include directives), but I still can't start game. It seems to me that it is UI problem because game engine itself works while UI does not. No assertion fails, segfaults etc.

    Comment


    • #3
      So... I did it! It works now but only in windowed mode. Now I am going to:
      1) Switch to DirectDraw7 and fix fullscreen troubles.
      2) Eliminate as much raw pointers as I can.
      3) Fix late-game crashes. Both CtP2 and Apolyton edition frequently crash at late game phase.

      Comment


      • #4
        OK, DirectDraw* is dead. it seems to me that I have to rework sprite engine in D3D11.It's a fckton of work but definitely doable. God help me but I want to implement all graphics using D3D11.
        PS God bless developers of CtP2, I just dont understand how they managed to implement all that raw pointers logic. That was time of heroes.

        Comment


        • #5
          PS I created the new project on github: https://github.com/RolandTaverner/ctp2. Hope it does not violate the EULA.

          Comment


          • #6
            You are our savior! Thank you for all your efforts!
            I tried to compile the source code months ago but i could not get it to work.
            Again, much thanks for your contribution!

            Comment

            Working...
            X