No announcement yet.

Win2000 - PC lockup at year 1320BC

  • Filter
  • Time
  • Show
Clear All
new posts

  • Win2000 - PC lockup at year 1320BC

    I am trying to run Civ2 on Win2000, but I am having some problems. The game runs perfectly fine until I reach the year 1320BC (turn #135), at which point it just freezes, and I have to End the program. I have tried this several times, starting a new game every time, but it crashes at the same point.

    Things I have done to try to resolve this issue:
    Installed latest Indeo drivers
    Installed the 2.42 patch
    Closed every other program
    Disabled any hardware that isn't required (USB, etc)
    Lowered screen res to 800x600
    Installed game to default location (c:\mps\civ2)
    Used Win2000 compatibility to run it as Win95/98

    As you may have guessed, none of this solved the problem. The last thing I tried was to enable cheat mode just before it crashes. I then changed the date to turn 137. After doing this I can play the game normally. If I then set the game back to turn 135 it locks up.

    Does anybody have any ideas on what could be causing this problem?

    Many Thanks


  • #2
    Wow! I must admit to feeling that we had seen it all here at ACS - but this one is new - and utterly intriguing.

    I assume that you have ensured your system is virus clean and does not have any spyware apps running in the background?

    My first thoughts are certainly inclined towards some kind of inter-application interference rather than to Civ being solely responsible...

    "Our words are backed by empty wine bottles! - SG(2)
    "One of our Scouse Gits is missing." - -Jrabbit


    • #3
      I had a similar thought last night, so when I got home, I updated my virus scanner & scanned my system - No virus was found. (I haven't checked for spyware yet though..I'll give that a go tonight.)

      I then thought it might be something to do with the harware in my pc, so I got my laptop out and installed it on there (this had a fresh install of Win2000 on it a little while ago, the only other software installed on it is Office). I copied across the saved game from my other pc and gave it a go, but I had exactly the same problem.

      After this, I started another new game and decided to not build up a big city, instead I just built my first city and just wondered the screen with a warrior. I locked in exactly the same place.

      I then started another new game, and enabled cheat mode straight away. I skipped to turn 134, then continued playing....guess what.. It didn't lock up!

      I'm running out of ideas now. I think I might try installing Win98 on a different hard disk and give that a go.

      Any more suggestions are very welcome.



      • #4
        Hmm, I use win2k, and have never experienced any of the many problems discussed here, though this is a new one on me.

        I can't believe you experienced this on 2 machines.....other than that I would say it was some hardware or software incompatibility quirk, which do happen a lot with old games.



        • #5
          Have you installed the latest Win2K Service Pack?
          Civilization II: maps, guides, links, scenarios, patches and utilities (+ Civ2Tech and CivEngineer)


          • #6
            Hmmm, isnt that the year where the civ 2 demo suposedly ended? (it was ages since I last played that, and it was for the mac version...)
            As I recall the demo dialogues are still in the game.txt of the full version so there might be some stuff left in other places as well...
            No Fighting here, this is the war room!


            • #7
              Originally posted by Henrik
              Hmmm, isnt that the year where the civ 2 demo suposedly ended?
              Wow I never knew that. If so this cannot be a coincidence.


              • #8
                This is wierd. I was playing about with CIV on my laptop over the weekend, trying to get it to work properly. I decided to create a new map. Would you believe it, it worked, I can just keep going and going, well into the AD years. So I guess there must be some kind of corruption in the maps when they were copied to my pc. I haven't tried it on my pc yet though...I got a bit carried away with playing it on the laptop! But at least I've got it working.

                Thanks for all your help guys



                • #9
                  Glad you can now join the community

                  "Our words are backed by empty wine bottles! - SG(2)
                  "One of our Scouse Gits is missing." - -Jrabbit