Announcement

Collapse
No announcement yet.

Freeze/Resolution/CTW crashes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Freeze/Resolution/CTW crashes

    Hi, i have some three very annoying problems:
    1. Every time I start a CTW-Game the programm crashes to the desktop and gives me a "exception-error" dialogue box.
    2. Playing the Scenarios also isn't possible. Towards the end the game freezes. Either sound or graphics hang and I have to reboot my system.
    3.Can't set my resolution to 1280x1024 16. It does the change, but the it freezes.

    I have a Kyro 3D Prophet 4500, AMD 900, win98se, VIA KT133a Mainboard. DirectX 9.0a is installed along with the newest drivers.
    So what to do?
    I read somewhere to check my IRQs, they share ressources as shown below but I cant change that.

    IRQ 5 VIA Tech 3038 PCI to USB Universal Host Controller
    IRQ 5 VIA Tech 3038 PCI to USB Universal Host Controller
    IRQ 5 ACPI IRQ Holder for PCI IRQ Steering
    IRQ 10 VIA PCI Audio controller
    IRQ 10 ACPI IRQ Holder for PCI IRQ Steering
    IRQ 11 LevelOne 10/100Mbps Fast Ethernet Adapter
    IRQ 11 3D Prophet 4500
    IRQ 11 ACPI IRQ Holder for PCI IRQ Steering
    IRQ 14 Primary IDE controller (dual fifo)
    IRQ 14 VIA Bus Master PCI IDE Controller
    IRQ 15 Secondary IDE controller (dual fifo)
    IRQ 15 VIA Bus Master PCI IDE Controller


    0 System timer
    1 Standard 101/102-Key or Microsoft Natural Keyboard
    2 Programmable interrupt controller
    3 Communications Port (COM2)
    4 Communications Port (COM1)
    5 VIA Tech 3038 PCI to USB Universal Host Controller
    5 VIA Tech 3038 PCI to USB Universal Host Controller
    5 ACPI IRQ Holder for PCI IRQ Steering
    6 Standard Floppy Disk Controller
    7 ECP Printer Port (LPT1)
    8 System CMOS/real time clock
    9 SCI IRQ used by ACPI bus
    10 VIA PCI Audio controller
    10 ACPI IRQ Holder for PCI IRQ Steering
    11 LevelOne 10/100Mbps Fast Ethernet Adapter
    11 3D Prophet 4500
    11 ACPI IRQ Holder for PCI IRQ Steering
    12 PS/2 Compatible Mouse Port
    13 Numeric data processor
    14 Primary IDE controller (dual fifo)
    14 VIA Bus Master PCI IDE Controller
    15 Secondary IDE controller (dual fifo)
    15 VIA Bus Master PCI IDE Controller
    Last edited by Sosoaha; June 10, 2003, 00:10.

  • #2
    Same problem ALOT of people have been having. Check the workarounds on this board but I'd mostly recommend waiting on the patch and hoping they fixed it. Given that I've read several places that this freezing problem everybody is having "can't be duplicated", I'm not holding my breath.

    Comment


    • #3
      The only workaround i found was setting agp size to 256MB. As i just have the option to set it to 128MB it didnt help me. I couldnt find any other workarounds for my Problems on this Board. Maybe someone can give me a link?

      Comment


      • #4
        Ok, looked around and found some, but none did any good for me (havent tried em all yet):

        "There is some additional spelunking that you could do that might help us out. In "rise2.ini" in your game directory, there should be a line that says "EnableGraphicsToggles=0". Change the 0 to 1. Then, if you go to the "Graphics" tab of the Options window, you should see a bunch of unlabeled checkboxes along the far left side next to each graphics type. These checkboxes enable you to completely turn off groups of renderings. By toggling these off, you might be able to isolate the problem to a particular section of the rendering code. This may get you playing the game and it might help guide us substantially. You can actually toggle these on and off in game; F11 brings up the Options menu without your needing to navigate through the UI. "

        "Typically, hard locks indicate a problem occuring in the video drivers. However, though less likely, it could also be in the sound driver. You could pretty much eliminate that as an issue by setting "Sound Enabled=0" in rise2.ini and seeing if that has any effect."

        "In newer bios:es there is an option called "performance" (or something like it) which is set at "optimal" at default.
        I simply changed that to "normal" (for increased stability) and voilŠ! It worked."

        "Hey mine works NOW! Donít know if this would help others, but I was about to reinstall RON because of the problem with CTW, but I uninstalled Game spy first, then I tried to run RON, and it worked! I still had it set to 32bit, donít know if uninstalling the Game spy actually did it, but before, I got it to work for 2 campaigns, after I changed the 16bit to 32 bit, but after the 2 campaigns it got the same error. But hey it works now!! "

        "I thought I would post this here as it might be something to try. I used to CTD with no errors on BF1942 and I read a post somewhere that the AGP buffer setting should be no more than 1/2 total RAM. At the time I only had 256 Meg and my AGP setting was 128. I reduced this to 64 and my CTD's went away. Upgraded to 512 Meg and changed the AGP buffer setting back to 128.....no CTD's."

        "All I did was change the screen resolution from 1024x768x32 to 1280x1024x32. Game has been stable since."

        "Change your graphics to 16 bit and see if that helps.
        I think its the other way around. I changed mine to 32 bit, and now the crash DOES NOT occur anymore. I can play CTW in full."
        (Setting from 16 to 32 crashed my game)

        "Just figured it out, was able to reinstall using the Add/Remove option after putting the CD back in, then selected Reinstall and checked the box to Copy existing files from Media. It reinstalled and when i rebooted and relaunched, the CTW continuing my campaign ran smooth again. So it was the Patch... Not patching until the next one comes out for sure."

        "I yanked the GeForce 3 ti200 out of my girlfriend's system and replaced my ATI Radeon 9500 Pro. Installed the latest drivers and I haven't crashed since."

        "Throwing my Radeon 8500 and my previous rage 128 pro out and replacing with pny geforce mx440 fixed my crash problems in Ron And EE Both!"

        "Actually I had problems with my second PC system which had an Nvidia Geforce 4 MX 440 SE which I took out and replaced with an ATI radeon 64MB which cured my problems."

        "I had a Radeon 8500 65mb, and it would lockup in almost all of my games. It would also cause windows to lockup when shutting down and sometimes when booting up.I tried everything and even 8+ HD reformats, as well as sending the card in for a replacement. But in the end I just got a "ASUS GeForce FX 5600" and now everything is FINE! NO PROBLEMS!"

        "I've had this problem in the demo and in the retail. After messing around I changed my screen resolution to 800X600 , I don't know why this works but it hasn't crashed since and I've played about 10 games. I have a radeon 7500 and win xp, who knows why this works, i'm just happy it does."

        Exception Error:
        "It's a longshot, but try going into your rise2.ini file and changing:
        FullScreen=0
        SkipIntroMovies=1
        ForceHardwareCursor=1
        ForceGDICursor=1
        ForceBWCursor=1
        CPU_grade_override(A-F or AUTO)=F
        GPU_grade_override(A-F or AUTO)=F
        TEXTURE_grade_override(FULL, HALF, QUARTER, AUTO)=QUARTER"

        Comment


        • #5
          I posted that work around to change the AGP apature to 256, this board won't let me edit the subject, but it's does not fix it, and I edited the post already.

          It must have been some fluke because it would crash inbetween 5-15min for me always, but when I changed the AGP apature size I played it for over an hour and quit. Next time I tried to load it back up it crashed within 5-15min again and always does again

          Comment


          • #6
            Dont beat yourself up over this. The problem is on their end. The total lack of commonality between people's systems, all of which are experiencing an identical problem, means that most likely it is not your hardware.

            I still think its a CD write protect problem. Its funny, we've heard zilch from the developers about what it is- indeed, they've suggested its our systems when its become patently obvious that its not .

            Comment


            • #7
              You're right... Will not touch the game again until the new patch comes. All those crashing und rebooting and
              ctrl-alt-enf really harmed my system! After one reboot i couldnt use certain keys!!! Ever heard of something like that? I couldnt believe that is possible.

              Comment


              • #8
                hehe skystreak I think you're totally right, there are so many people with the exact same problem, and there are so many different problems with the game.

                At least with the freezing issue that locks up the computer randomly, it's not a copywrite CD protection, because the demo does the exact same thing

                Comment

                Working...
                X