Announcement

Collapse
No announcement yet.

artilllery bombard doesnt work properly

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • artilllery bombard doesnt work properly

    Since I've added the source code project in I've noticed that my artillery will not bombard across two spaces anymore but can only bombard directly adjacent squares. The AI doesn't seem to have this handicap.


    Edit: Also I have noticed a few other strange things. Sometimes I will be researching one item but later my research is moved to something else without my knowledge. The game forced me to wait through two other researches while I kept choosing "railroads" every time

    Also sometimes my units attack on their own.. usually suicide attacks so that is pretty annoying.

    Also I tried to edit strategies.txt to make the AI build cities further apart by changing the minsettledistance value. This seem to work 9/10.. but there is always one that continues to build cities overlapping their original 9-square area!

    The AI seems to be doing much better in general.. too bad these other strange things are going on so I cannot really use it though!
    Last edited by RolandtheMad; April 27, 2014, 01:21.

  • #2
    Originally posted by RolandtheMad View Post
    Since I've added the source code project in I've noticed that my artillery will not bombard across two spaces anymore but can only bombard directly adjacent squares. The AI doesn't seem to have this handicap.
    Does anyone know about this bombard issue? Maybe I am crazy and thinking about another civ game where you are supposed to be able to bombard across two squares.

    The other issues mentioned still stand, but I have reinstalled CTP2 without the Apolyton update since it seems to be doing strange things. It is too bad because the AI was playing a much better game otherwise!

    Comment


    • #3
      Sometimes I also mix-up some Civ. I also remember to be able to bombard over two squares. I think it was Civ4.

      @RolandtheMad, I tried to write you an anwer, bu I am not alowed to send messages until I have 10 posts. So I copy&past it here:




      Thank you very much! It helped me a lot!

      I found this:
      htxp://apolyton.net/showthread.php/172035-PROJECT-Playtest-%28Thread-No-6%29
      #4 How should I report a bug?
      [...]
      You can enable crash logging by editing your userprofile.txt (in [Your CTP2 directory]\ctp2_program\ctp\) to set EnableLogs=Yes. The log can then be found at [Your CTP2 directory]\ctp2_program\ctp\logs\crash.txt.

      So I got a crashfile!
      And there I saw that I wasn't using the newest version of the game. I duno why, I downloaded it in 2012 I thought I was using all over the time. Well, but I wasn't. So I applied the new version to my game and started again, made the reload to my savegame ("All you need to do - after loading your save game - is to
      open the chat window by typing the apostrophe key (') and enter: /reloadslic") and it worked! (I only tried one round.)

      It would be nice to give this game a bit of new life. There is no compareable game out there which is as good as this (world strategy genre).

      Now I hopefully can finishing konquer the world (I am in year ~2060)

      thx & cheers

      Comment


      • #4
        I'm glad it helped you. I didn't have much information but it was more than nothing!

        This game is so old. I am surprised that as much work was put into it as they did with the source code project. It was originally released in Nov. 2000. It is almost 13 years old! Even just looking at the file size is hilarious. I think the GOG download was 400meg total.. that not even a whole CD worth lol let alone a DVD which are getting crammed full with the newer games. I just wish that the weird problem with the research wasn't there because that basically was the deal breaker for me with the Apolyton update. Going back to the original version it is clear how much they improved the AI!

        Who are you conquering the world as? I'm playing Japanese right now trying to keep France and Spain to my north busy fighting each other while I chip away at Portugal to my south who is just too damn big! Somehow Portugal conquered Ethopia early on and a big part of Greece and their score is double mine, and mine is the highest out of all the other AI players.

        Comment


        • #5
          400MB was quite a lot in 2000. But Win XP was also 14 years old until it died BTW there are other old games: hxxp://wz2100.net/ Warzone 2100 is even older (1999). And with still an active community. Today it is completly open source, probably this is the difference which made wz2100 more sucessfull than ctp2...

          Hey, I am Japanese too, right now! I researched Fusion now and with the Fusion Tanks it is quite easy to conquer. The AI started to build cities in the sea (a lot!) so my ships have to raze them Sadly they do not defend them. I am now in a state where nobody can hold me back. Even if I still have not the strongest army, my tanks rule the world. I have now 88 cities while the 2th 35. My score is now half of them what the other 4 AIs have together...

          For me this game is still fun, even if the end is always a bit the same (I wait until I have tanks and then I go to war). The beginning was very hard (I took the hardest settings possible). I had to struggle to survive and give some gold to keep peace But with tanks, everything changed.

          Comment

          Working...
          X