No announcement yet.

Game crashing on start in Windows 8

  • Filter
  • Time
  • Show
Clear All
new posts

  • Game crashing on start in Windows 8

    Hi friends:

    Wayyyy back in the day I played CtP 1 on Mac. I now want to play it on my Windows 8 64 bit computer. I bought the CtP Windows CD on eBay. I have performed a full install, installed 1.2, and installed 1.2.1. The install path is C:\Program Files (x86)\Activision\Civilization-Call To Power\ctp_program\ctp

    Unfortunately, the game crashes on start.

    The screen goes black. This lasts for three seconds or so.
    A small amount of light comes into the screen. Just a little gamma. The sound of the intro splash/logo screen followed by the intro movie begin. The video does not play. This lasts until the end of the intro video or until I click my mouse.
    The screen goes completely back. A windows dialog box pops up telling me: "Civilization: Call to Power has stopped working A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." This dialog box is large, indicating that the resolution has been adjusted. I am given a "Close program" button. Using this button returns me to a normal view of my desktop, with Call to Power closed.

    At the time of these crashes, the following error is logged in Event Viewer > Windows Logs > Application:
    Fault bucket 744975459, type 1
    Event Name: APPCRASH
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: civctp.exe
    P3: 37d6f702
    P4: civctp.exe
    P6: 37d6f702
    P7: c0000005
    P8: 00004a33

    Attached files:
    C:\Users\Marshall\AppData\Local\Temp\WER71D9.tmp.W ERInternalMetadata.xml

    These files may be available here:
    C:\ProgramData\Microsoft\Windows\WER\ReportArchive \AppCrash_civctp.exe_f383c6ea4dcee1402623c346c249b 95a90f1b31a_e13efadf_15b6beb1

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: 599e385e-2a9c-11e5-bed4-d43d7ea63a31
    Report Status: 0
    Hashed bucket: 3dd004ea3a50bd928f087e5fb1a57b0c

    I have tried setting Compatibility Mode on civctp.exe for Windows 95, Windows 98, and both available versions of XP, but this has had no effect.

    This thread suggests certain specific codec work, and I attempted to follow it:
    1. I had trouble finding "codinstl's iv5 codec", but eventually downloaded and installed codinstl.exe from here and executed it:
    2. I did copy all files beginning in "ir" from C:\Windows\SysWOW64 to C:\Windows\System32, choosing not to replace existing files.
    3. I did install Combined Community Codec and choose to reset all codecs during the installation.

    Unfortunately, this has had no effect.

    I'm not sure what to try next, and I would be grateful for advice or direction. Thanks!

  • #2
    Try installing and running as Administrator.


    • #3
      Originally posted by ricketyclik View Post
      Try installing and running as Administrator.
      I previously had installed CtP normally but used Run as Administrator on the patches. I have just uninstalled CtP, then reinstalled it with Run as Administrator, then also run the 1.2 and 1.2.1 updates as administrator. This has not made any difference. The symptoms are still the same. Thank you for the suggestion, though. Any other suggestions, even a stab in the dark, are welcome. <3


      • #4
        I have partially (and acceptably) resolved this issue. Altering the configuration file to turn off full screen videos solved the problem. Videos still fail to play when I launch the game, but there is no longer a crash at the end of those videos. This is acceptable to me, since I would be unlikely to watch the videos at program launch most of the time, anyway.

        It is probable that some of the troubleshooting I did on this issue was unnecessary.

        For future users in the same situation, here is a summary of the procedure that I believe was minimally necessary for me to run Call to Power for Windows on my Windows 8 (Home Version), 64 bit computer. Note that I did a few other troubleshooting measures, documented in my first post, but I do not believe they contributed to my ultimate success:
        1: Insert the CD into the CD drive.
        2: Navigate to "This PC" (which is just the Windows 8.1 name for "My Computer").
        3: Right-click on the CD.
        4: Select Open.
        5: Right-click on Setup.exe.
        6: Select "Run as Administrator".
        7: Perform a full installation. Don't register, don't change the installation path, and say yes to everything else.
        8: Download and save to your hard drive the "Patch: English Updater 1.2" official patch and the "CTP 1.21 Hack" fanmade patch from Apolyton's Call to Power I patch download page, which can be found here:
        9: Right-click on the 1.2 patch.
        10: Select "Run as Administrator".
        11: Perform the update.
        12: Right-click on the 1.2.1 hack.
        13: Select "Run as Administrator".
        14: Perform the update.
        15: Navigate to C:\Program Files (x86)\Activision\Civilization-Call To Power\ctp_program\ctp
        16: Launch civctp.exe (expect a failure in which opening videos play audio but not video, then the game crashes).
        17: When you launched civctp.exe, two new files were created in C:\Program Files (x86)\Activision\Civilization-Call To Power\ctp_program\ctp. You need to change one of these files. Open userprofile.txt in that location.
        18: Find the line that reads "FullScreenMovies=Yes" and change it to "FullScreenMovies=No".
        19: You need to save this file, but Windows will probably stop you from saving it directly to this location. Close your text editor, and when prompted to save, save the modified file to your desktop.
        20: Make sure that userprofile.txt is selected. Hold the shift key on your keyboard and hit the Delete key on your keyboard. Windows will probably prompt you asking if you want to permanently delete this file. Say "Yes". Windows will then probably say you need Administrator access. Allow this. The file should then be deleted.
        21: When the file is deleted, move the copy of userprofile.txt from your desktop to C:\Program Files (x86)\Activision\Civilization-Call To Power\ctp_program\ctp
        22: Try launching civctp.exe again. This time you are expecting the videos to fail to show video (still only audio), but after they end the game will not crash.
        23: Conquer the world (or do alien stuff, I don't care, I'm not the boss of you).