Announcement

Collapse
No announcement yet.

windows 7 problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • windows 7 problem

    I'm having trouble playing the game in windows 7 and 8. I have a computer with once and a laptop with the other. The game worked fine until a couple of days ago in windows 7, but now it loads up the intro video and the crashes the game leaving a black screen with the music still playing and the mouse frozen. I have to restart my computer with the arrpw keys to fix the problem. I reinstalled the game and even installed it on the windows 8 computer and get the same results. Also I tried to install an older version of indeo 5 but it says it can't even though I deleated the newer version, it still says that there is already a newer version on it. Can anyone helpme? I also have all the patches on it too.

  • #2
    ok found a partial work around. in the victorymovie and wondermovie files, change the names of all the movies to "null". This tells the game that there is no movie for that event and to go on with its business.

    My new problem is there is no sound other than the game music. I'm currently checking if it is an audio driver issue and or if it isn't reading it from the zsf file it is in.

    Comment


    • #3
      found a fix. took 3 days of searching for codecs, drivers, and reading code for both the game and codec files. First install by running as administrator codinstl's iv5 codec. Then go to SysWOW64 folder inside the Windows folder. Look for any file that begins with ir such as ir50_30.dll and so forth. Copy all those files and paste them into the System32 folder. If there are any files there already, just keep the original instead of overwritting them.

      Now, this may or maynot have anything to do with it, but I did this instead of testing to see if the above worked. Why I don't know, just tired I guess. I then followed up by installing the Combined Community Codec pack as administrator and when prompted, I reset all codecs. I then reset the computer and enabled movies by pasting back in the original victorymovie and wondermovie files, and all worked.

      I tried the same with a new installation onto my windows 8 laptop and it works. Also, I followed up by setting the trywindowsresolution setting of the userprofile file to Yes. Makes everything look snazier. Oh this works for CTP2 also, as I have both and installed both.

      Comment


      • #4
        I recently installed Call to Power 1 on a Win7 64 bit system.
        Nevertheless istalling it went fluently, starting it does however not.
        I get all the way to the startup menu (with the start and uninstal button)
        but once I click start, the screen gets black (no video is shown)
        however the screen resolution size does change to the size normally needed for this game after that,
        and the music that is normally played during the opening video does play.

        since I get no video, I cannot click any start a game button either.
        any suggestions how I could fix that?
        (ofc I do have updated it to 1.2 in case you wonder)
        I also have CtPII on my system and that works without trouble.
        However I find the experience of CtP2 (the space map, and certain other things removed in CtPII) more enjoyable,
        and would really like to get CtP1 to work as well.

        Comment


        • #5
          sounds you had the same problem togewa.. however your solution, does sound a bit complex to me.. can you repeat your fix for this problem, in a slighly more noob understandable way (for example better say what programs I need and where I can obtain them)

          Comment


          • #6
            no problem. just download codinstl's iv5 codec and the Combined Community Codec. They can both be googled. Install codinstl first. then click on the my computer icon. It looks like a computer and monitor. Then double click the C: drive. Then double click the Windows folder then the SysWOW64 folder. In this folder, there are some files such as ir32_32, ir41_32ax, ir50_qcx and so on all the way to irprops.cpl. select all those ir files and copy them. then go to the System32 folder and paste the files to it. Windows may ask you if you want to copy over some of the files that are already there. In all those cases select no.

            Then install the Combined Community Codec. Towards the end of the install there will be a checkbox for you to check stating reset all codecs. Check that box and finish the install. Then all you have to do is reset the computer and voila.

            There isn't any magic easy button. just remember when in doubt Google it.

            Comment


            • #7
              An easier way is to follow these instructions that I found on this site www sevenforums com/music-pictures-video/148954-indeo-5-x-codec.html I also did the coping of the ir dll files to system32 folder

              Open a 'command prompt' using a right click, select, 'Run as Administrator'
              Type: cd C:\Windows\SysWOW64 (32bit users can skip this step) - press enter
              Type: regsvr32 ir50_32.dll - press enter

              To undo what you have done, type: regsvr32 /u ir50_32.dll
              There is an error during unregistration, but it does remove it from being active

              Comment


              • #8
                Okay, it's been a while since I've played this game (read: a few months), but I decided to try it again. So I'm fairly certain that I've installed both the game and the 1.2 update in XP compability mode as an administrator. I've got the FF mod (with 1.76 hotfix) molded into my game files correctly and I've followed these instructions I've seen on this thread. However, the game is still not working. I have successfully played the modded game on this computer before, but now it just doesn't want to load after I hit 'Launch' on the new-game-screen. It only loads to about 40% percent until it freezes or crashes to desktop. Maybe it's due to disc error, the disc is almost as old as the game itself, so it may have something to do with that.

                Comment


                • #9
                  I had to create an account because your solution worked for me. Thank you for your help I was struggling all of yesterday trying to get this to work. Now to play ^_^

                  Comment


                  • #10
                    Bạn đă kết nối với 1 máy tính khác,
                    VietLines chuyên cung cấp các tour du lịch tuyến du lịch nội địa: du lịch sinh thái , du lịch cộng đồng , du lịch sinh thái Khe Ro , .....

                    Comment


                    • #11
                      Bạ has nghĩ máy tính của bạn đă bị nhiễm virut, hăy kiểm tra lại nhé
                      VietLines chuyên cung cấp các tour du lịch tuyến du lịch nội địa: du lịch sinh thái , du lịch cộng đồng , du lịch sinh thái Khe Ro , .....

                      Comment

                      Working...
                      X