No announcement yet.

Installing Call to Power II Problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing Call to Power II Problem

    Sorry if this isn't the right place to ask this, but I don't know where else to look. I've owned CTP II for some time, and recently had to format and renew my system. When I got to reinstalling CTP II, installation begins as normal, stops at precisely 8.3% installed, hangs for a while, as the concept art and music continues to play, then says "an unrecoverable has occured while attempting to install Call to Power II."

    I've never had this happen with the game before and have no idea how to fix it. Can someone help?

  • #2
    It sounds like the CD is damaged, try it on another pc to check, if it works re-format your drive and try it again, if it still doesn't work take it back to the shop.


    • #3
      Or you could just take it back to the shop straight away.


      • #4
        What Windows Version are you running? There have been quite a few people have problems in the past, you might be able to find the threads on the later pages here. I think it was Win2000 gave problems but solvable ones, and Windows ME wouldn't install it at all.
        I suggest looking for a previous thread unless someone else explains further.
        Concrete, Abstract, or Squoingy?
        "I don't believe in giving scripting languages because the only additional power they give users is the power to create bugs." - Mike Breitkreutz, Firaxis


        • #5
          Windows 2000 with sp2. I examined the CD closely, it has no dents, scratches or other deformaties, and it hasn't been smashed or dropped recently. I polished it up really good and tried installing again, this time I got as far as 14% before the unrecoverable occured. Maybe I just need to keep trying.

          Um, if you don't mind, I have a few more questions, from reading threads I've found on this forum. When is Civ 3 coming out? Is there any idea of a release date?

          Second, what are the "mod" patches for CTP2? Assuming I can finally get the game running, what do they do? Make it more fun? Harder? One of the things I can't stand about CTP2 is the AI being rather poor when it comes to interacting with me, the live player. Another thing that bothers me is that no matter what, even if I personally have a peace treaty with every other Civ, they all spend virtually the entire game with war declared on every other Civ. I hate that, it's completely unrealistic. If our own world was like that we'd all have been dead years and years ago.


          • #6
            I don't know anything about your computer, but I'm running Win2000 with sp2 and I haven't had a single problem. If it's the computer and not the CD, then I don't have a clue.

            Also - you might try cleaning your CD-ROM drive. You can buy a cleaning cd thingy for it for about $5 that actually works pretty well.