No announcement yet.

CTD on city mgr screen

  • Filter
  • Time
  • Show
Clear All
new posts

  • CTD on city mgr screen

    Oh my god...! I've found folks who actually still work on this game! Gods be praised.

    Okay, to my question: one of the very irksome things for me in this game (more irksome because I think CTP2 is probably the coolest civ game yet) is a CTD that happens when, later in the game, I click on the city manager screen. Started again last night, just after I settled my 39th and 40th cities. Too many cities?

    Running XP now, 512 RAM. Also occurred in Win95. Any thoughts, fixes, more info needed?

  • #2
    Do you have the patch and are you using any mods?


    • #3
      1.1 installed, but no mods.


      • #4
        It looks like your governemnt doesn't allow 40 cities so get a better government in the mean time every city over the limit, removes one point of happiness in every city of your empire.

        Civ2 military advisor: "No complaints, Sir!"


        • #5
          Hi Martin.

          Thought of that. Going over the gov't limit normally causes unrest, not a crash. But in this case, I'm a Corp Republic, so 45 cities should be acceptable.


          • #6
            can you try to attach a savegame?
            Might be something wrong with the savegame.....
            Did you ever reload in between from the Autosave?


            • #7
              Hi G,

              Interesting thing, it occurs sporadically. Last night, I was able to play a few turns without problem (I recall this happening before, too). Then, when I play long enough, it'll crash again. Seems to happen when I have plenty of cities and (necessarily) later in the game. IOW, it'll happen again. Perhaps a memory leak???

              I can attach a game the next time it crashes, send to you?



              • #8
                If the game is crashing (I don't know what CTD is) try the /reloadslic trick after you have loaded your saved game.

                Hit the ' touch and then enter /reloadslic in the text window, hit Enter to execute the command and then Enter again to close the window.
                "Democracy is the worst form of government there is, except for all the others that have been tried." Sir Winston Churchill


                • #9
                  Hi T,

                  Okay, I'll try, see what results.

                  CTD=crash to desktop.



                  • #10
                    And in case it happens send the save, we will have a play


                    • #11
                      Okay, it's still happening. I've a file, but how do I get it to you guys in order to take a look?

                      Many thanks.


                      • #12
                        Use a program like winzip or windows XP's file compressor, to put it into compressed format, and than use the attach file button from the "post reply" screen. Simple as that


                        • #13
                          BTW Toro, if you are experiencing repeated CTD you can try to install again CtP2 using the Compatibility Tool provided with XP. I am using Win2000 and this tool has often allowed me to solve problems.
                          "Democracy is the worst form of government there is, except for all the others that have been tried." Sir Winston Churchill


                          • #14
                            The file.

                            Thanks for assist here.
                            Attached Files


                            • #15
                              I played about 12 turns and no problems anyway, except for switching you to a commie
                              Attached Files
                              Call to Power 2: Apolyton Edition - download the latest version (12th June 2011)
                              CtP2 AE Wiki & Modding Reference
                              One way to compile the CtP2 Source Code.