Announcement

Collapse

Welcome to the New Server!

Apolyton.net is now pointing to the new server. Please let us know if you spot any oddities or have any suggestions for what to add to the site!
See more
See less

How do I make custom maps or scenarios work with multiplayer?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do I make custom maps or scenarios work with multiplayer?

    Hello!

    I've spent hours with both Civilization: Call to Power and Call to Power II, trying to make the custom maps I create work in multiplayer mode. I have some friends I'd like to play a custom map with, but I can't get the game to launch!

    I've tried saving the custom maps as scenarios, and as a regular saved game. I've even tried copy and pasting the saved files into the "mp" folder. After that didn't work, I tried every other folder I could find that would have saved games in it. Thus far I've been unable to load any custom-built scenarios. I have managed to load a saved custom map in Call to Power II, but the game won't launch. When I open it, only my name shows up in the player list. The AIs don't show up. I can't add AIs either, which isn't important anyway.

    This is what I want to do:

    I want to start a single player game. Without taking any turns, I want to make the entire map visable, then add some goods, change some tiles, and even place some units here and there. (I know how to make the above changes already.) I then want to exit the altered scenario, enter multiplayer mode, then load the map I just finnished customizing. I want it possible for others to join after the game is launched(via dynamic join), and I also want it possible for others to join from the lobby, before I launch the game.

    If this is possible with Civilization: Call to Power or Call to Power II, please give me thorough instructions on how to achieve this.


    Failed attempts:

    - I've tried saving as a scenario, then loading the scenario, but the scenario did not appear in the scenario list. (Only the example thing would show.)

    - I've tried creating a regular multiplayer map with dynamic join, then exiting the game, copying the saved game file into the single player saved game folder, then loading the multiplayer saved game from the single player mode. My intention was the alter the map after it had already been created as a multiplayer one, but this attempt failed.

    - I've tried (several times) creating a single player map, editing it, exiting the program, then copying the file into other folders containing multiplayer maps (including scenario folder and folder labeled "mp").

    - I've tried finding directions in a README file. I read about 5 README files, which contained no useful information.

    - I've tried the activision site for help, but they don't support the cheat mode for customization or scenario creation.

    Note:

    - I had almost concluded this task was an impossible one to achieve, until a friend told me he'd successfully created and played a custom map in multiplayer mode in the past. Unfortunately, he does not remember how he did it.

    - I tried finding this information on the forum, as I suspect these questions have already been asked. I'm sorry if this is the case. Call me a n00b if you'd like, but please have patience with me.

    Thank you!

  • #2
    Hi SirDeity, nice to see you here

    One thing to try is, make your scenario, save it into the scenario structure, then exit the whole game, and load up the scen in single player, then save it as a normal save game, move the regular save (not the scen save/directory) to MP save directory, then try loading it as a MP save. If i misread your post and you already tried this then
    Call to Power 2: Apolyton Edition - download the latest version (12th June 2011)
    CtP2 AE Wiki & Modding Reference
    One way to compile the CtP2 Source Code.

    Comment


    • #3
      Thanks Maq. I'll give it a quick attempt. I'll be right back with the results...

      Comment


      • #4
        Try this with ctp or ctp2? I'll try both...

        Comment


        • #5
          Civilization: Call to Power results:

          I saved it as a scenario as you suggested, then tried loading it in single player after completely exiting the program. First I selected "New Game," then "Select Scenario," but the saved scenario was not listed as a scenario. Only the "Example Scenario Pack" --> "Example Scenario" was listed.

          Apparently I don't even know how to play a custom-built scenario in single player mode.


          I'll try it in ctp2, and will return shortly with the results.

          Comment


          • #6
            Yeah, i shouldve said, my thoughts were for CTP2.
            Call to Power 2: Apolyton Edition - download the latest version (12th June 2011)
            CtP2 AE Wiki & Modding Reference
            One way to compile the CtP2 Source Code.

            Comment


            • #7
              I got it to work with CTP2. Thanks for the help.

              Comment


              • #8
                In CTP in order to make a scenario appear you have to add several text files. The details are in a readme (no, really they are ), or you can find them in the CTP modification guide on my website (link above). You should then be able to start an MP scenario.

                Comment

                Working...
                X