Announcement

Collapse
No announcement yet.

1.17f Bug, Nasty Army Bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1.17f Bug, Nasty Army Bug

    Note: Not sure if this has been mentioned

    The previous turn I used my Armies to defeat an Egyptian city. Next turn I go to look for them and the units that were in the armies are no longer there.

    When I had an army selected you would see the arm guy with his flag, but no unit next to him and then there was a unit a few squares away that was also high lighted. Although it is not shown in the picture that is below, sometimes you could see the big army health bar a few squares away from the arm, I will try to get that pic and post.

    That unit was also turned into a position that I never see in a panzer. When I loaded a unit on to the army it was not visible.

    Here is a picture that might describe it better:
    http://mywebpages.comcast.net/jcaniglia/

    Then end result is that it looks like I will have to disband the armys

  • #2
    Were you using stacked movement? I've discovered too where if I used stacked movement that units would unload from the army. For example, I had an army of tanks, along with a whole bunch of more tanks. I hit j, and sent them off to their next destination. Apparently, the stack movement code grabs the tanks right out of the army group, and moves them to the destination. The army group stays behind because stack movement only works with one type of unit at a time.

    Actually, this bug can be quite useful. People have been annoyed by being unable to unload units from an army, and being unable to upgrade those units. Now you can stack-bug them out, and upgrade your army to the latest and greatest. Or perhaps when one is done with an offensive, unload the tanks and stick infantry back in.

    I'd label this as an unintended but useful glitch.

    Comment


    • #3
      I will be posting a Save soon

      I guess NO one believes me so I will have to go with the hard evidence. I will be posting a save game soon.

      I was typing the above while randommushroom did his post. I am not sure if that is what I did, but I just tried it from an earlier save and sure enough it did happen.
      Last edited by I Am Jeff; February 21, 2002, 14:09.

      Comment


      • #4
        I have noticed something like this when stack moving a bunch of tanks. I had an army (three tanks) stacked with about 10 tanks. Stack moving it screwed up the graphic of the army like you said. Apparently you can use this to upgrade units in armies, but I didn't have Synth. Fibers yet, so I couldn't try it.

        -Arrian
        grog want tank...Grog Want Tank... GROG WANT TANK!

        The trick isn't to break some eggs to make an omelette, it's convincing the eggs to break themselves in order to aspire to omelettehood.

        Comment


        • #5
          How the heck did you get tanks in 10 BC???

          Comment


          • #6
            I duno how i got tanks in 10 B.C., but many other civs have tanks and I did not trade it to another cpu. Usualy i get tanks fairly early, earlier then you should. This was the earliest. It is not that I am greatly more advanced then other civs. We are all about equal in tech. Then other civs even get some techs before me.

            Comment


            • #7
              I'm not doubting the Army bug at all, but something is seriously messed up with that screenshot. Not even counting the tech level, there is no way there could be that many cities with that much terrain improvement by 10BC. It's just not possible for all civs to produce that much crap in that period of time. I'd guess a date hack has been used (not that it matters one bit, I'm just saying...)

              Comment


              • #8
                I duno how i got tanks in 10 B.C., but many other civs have tanks and I did not trade it to another cpu. Usualy i get tanks fairly early, earlier then you should. This was the earliest. It is not that I am greatly more advanced then other civs. We are all about equal in tech. Then other civs even get some techs before me.

                Comment


                • #9
                  You don't have to disband them. Just put some more tanks in there. That worked for me. I had an Army of Cav. along with 5 other cav units. Used that stack movement, and ended up with what you had. But I was able to take four tanks and refill the army...

                  Comment


                  • #10
                    There was no date hack used. It is turn 126. I have 68 saves showing the corse of the game, (about 195 mb). An explanation to why I am so advanced may lie in my editing of the civ3mod.bic

                    A big change I made was that wonders never expire. Another one is that for luxury resorces I put in numbers for appearance ratios, for some reason luxury resorces now bunch together sometimes in large groups. The biggest of these groups I have seen are 20 of the same luxury in one spot. If someone were to build a city in one of these groups, then add the Wonders, The Colossus, Newton's University, and Cornipicus' Observatory. Then add improvements Library and University. You will get a lot of trade with can translate in to tech. One city in one of these bunches has a tech per turn of 385, with the slider at 50%.

                    Another I did was the allowing of minning in forests (which is done in real life). So cities with no hills or mountains would be able to produce something.

                    I also want to point out that I hardly traded techs with the cpu, so they did not have a human player feeding them techs. Some cpus even got techs before me. Also in that screen, the improvement see was done by the cpu.

                    I do have to admit I advanced much faster in this game then in the previous one. In my other game I got tanks around 850 A.D.
                    However I had the same amount of cites and land improvements as in this current game at this time.

                    I now have another pic of something that this army bug did. It is of a tank and his health bar is messed up. It has 2 normal health bars, then blurs, then goes to health bars of the size of a full army. I tried attacking and the game crashed. I solved the problem by disbanding the unit.
                    Attached Files

                    Comment


                    • #11
                      I'm curious about why you blanked your civ's name out.

                      Yeah, I ran into the army bug, and moving the units around too much caused a crash. I reloaded and prevented the bug by moving the army prior to moving the stack.
                      Above all, avoid zeal. --Tallyrand.

                      Comment


                      • #12
                        I blanked the name because it is my name, then i realized it did not matter because you could see it from the link to the pictures in the first post. I guess I am just paranoid. If u realy want I can post the pic without the blanked name, when my webspace decideds to let me upload new files.

                        Comment


                        • #13
                          I just experienced another odd thing that has to do with this army thing. If you are to do the stack movement, thus removing the units. Then take the empty army and move it to a square that either has no road or rail road. The army will move, 1 unite will move with it, then the other units will slide directly towars the army to be par of it. I tried to get a good shot and I believe this is the best one I got of this.

                          I will try to upload a save somewhere so people can try it for themselves and see it as well.
                          Attached Files

                          Comment


                          • #14
                            Please tell me you Edited the game before playin or else please tell me how the hel| you got all them tanks in 10 B.C.!!
                            -Never argue with an idiot; He will bring you down to his level and beat you with experience.

                            Comment


                            • #15
                              Spec, he posted about it. It actually sounds pretty cool really.
                              Above all, avoid zeal. --Tallyrand.

                              Comment

                              Working...
                              X