No announcement yet.

Civ2 won't run on Windows2000

  • Filter
  • Time
  • Show
Clear All
new posts

  • Civ2 won't run on Windows2000

    I'm having trouble running Civ2 on Windows 2000. I have loaded the civ242 patch, and it still won't run. The error message is: "CIV2 caused a Stack Fault in module IR41.DLL at 0002:019D." Then the only option is to close the application. Has anyone else run into this problem and, if so, were you able to fix it?

    BTW - I'm running a Creative Labs Annihilator 2 (GeForce 2) graphics card.

    If you know of a fix for this, please e-mail me.
    [This message has been edited by Palpatine1969 (edited December 22, 2000).]
    [This message has been edited by Palpatine1969 (edited December 22, 2000).]

  • #2
    microsoft sucks.


    • #3
      Civ2 (2.42) works perfectly fine on my Win2k machine at work. Do you have SP1? Looked into video drivers, made sure everything is updated via Windows Update?


      "Let us kill the English! Their concept of individual rights could undermine the power of our beloved tyrants!"

      ~Lisa as Jeanne d'Arc


      • #4
        I have seen two threads saying the win2000/civ2 compatability problem can be solved by a windows file named winG.dll (the G is uppercase). The poster said the file could be download from the windows website, and one post suggest (a little unclearly) that the winG file was on the windows2000 disk but was not part of the automatic install and that it could be installed manually. From the thread I got the impression that it had something to do with several 16 bit games operating with the 32 bit windows.

        Gaius Mucius Scaevola Sinistra
        Pontificator Pendanticus
        older richer & wiser than you
        [This message has been edited by Lefty Scaevola (edited December 22, 2000).]
        Gaius Mucius Scaevola Sinistra
        Japher: "crap, did I just post in this thread?"
        "Bloody hell, Lefty.....number one in my list of persons I have no intention of annoying, ever." Bugs ****ing Bunny
        From a 6th grader who readily adpated to internet culture: "Pay attention now, because your opinions suck"


        • #5
          Strange how the world works. Or doesn't in this case. I loaded civ2 on my win2000 machine yesterday and I got the same error. I knew there would be issues when the install wanted to add a video player.

          No I don't have a solution.

          Honestly, I think this in MS's way of getting us to play Age of Empires.
          Banano Laŭrajta Registaro en Ekzilo - Bananoj gismorte!| Cows O' Plenty|Wish List For ciV | Ming on Spammers: ...And, how do you know that I'm not just spamming by answering him |"This is all about peace; and in the quest for peace you have none." -my son wise beyond his years


          • #6
            WinG is included in a subdirectory on my 2.42 disc.

            St. Leo
            Blog | Civ2 Scenario League | leo.petr at