No announcement yet.

windows xp

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by timmy_otoole
    Googlie, I have tried clicking yes to the, "do you want to play anyway?", but SMAX just quits to the desktop.

    Here is something more odd. I can get SMAC to run if I *don't* apply any patches or updates at all. As soon as I apply any patches or updates, I get the "don't support this CPU" message. Though SMAC is fun, I would prefer to get SMAX to run correctly.
    This is what worked for me. I loaded both games, and then applied only the SMACX patch, with no SMAC or XP patches. It worked. This was of course after trying like hell to get the game to work with both the SMAC and SMACX patches. I don't play much plain SMAC, so I can live with this. I haven't tried the XP patch at all, it wasn't out when I got this machine, and it isn't recommended unless you are having problems.
    He's got the Midas touch.
    But he touched it too much!
    Hey Goldmember, Hey Goldmember!


    • #17
      I had the same problem (new system, new pentium P4, WinXP). I applied all the patches including the "ini" file fix and it didn't help.

      What worked for me was applying the "no CD" crack (the one that allows you to play the game [Alien Crossfire] without a CD in the drive.

      You still get the CPU error message but now you can say "okay" and it will proceed with the game (before it just dumped me back to the desktop).

      Alien Crossfire has the "Safedisc" protection on it (that's what requires you to have the CD in the player). Get one of the safedisc remover programs (I used "Safedisc's free, readily available and easy to a "Google" search for it).

      Good luck.


      • #18
        I just purchased an Alienware notebook computer (Pentium4 2.5GHz, 512MB, WinXP Pro) and upon installing Alpha Centauri and Alien Crossfire, I too am getting this CPU error. I too press "OK" but the game still aborts.

        Is this no CD crack the only way to get it to work?



        • #19
          Never mind. I solved it using the tips from this thread plus an extra Google search finding this site:

          * I installed the Alien Crossfire patch.
          * I uninstalled the WinXP Compatability (I had installed it prior to reading this thread).
          * I set ForceOldVoxelAlgorithm=1 in the Alpha Centauri.ini file.
          * I opened Alien Crossfire from the terranx.exe (rather than the shortcut installed in the Start Menu).
          * I said "OK" to the CPU error message.

          This combination worked for me, and hopefully they will work for anyone else with this problem.



          • #20
            And here I am with a similar problem now. I could play the game fine earlier today, but for some reason I can't fathom, it won't work now. I'm going through the following and hoping it'll work.

            1) Uninstall XP Patch
            2) Uninstall Planetary Pack
            3) Check C:\windows\ for any file still remaining there (SMAC*.*, Alpha*.*, Firax*.*, etc), and delete
            4) Kill all SMAC and SMAX related entries in the registry
            5) Reboot, run Registry Cleaner from j16 Power Tools, and run other system cleaning related programs to try and get the best possible base to install from
            6) Reboot again, and install of CD
            7) Reboot, and install XP patch
            8) Set .ini file for ForceOldVoxelAlgorithm=1
            9) Try and run the games from their executable files.
            Veni Vidi Castravi Illegitimos


            • #21
              Didn't work. =/

              Got errors trying to run both SMAC and SMAX before and after the Compatability Patch / No CD Patch, with ForceOldVoxelAlgorithm=1 already set. I'm assuming I need to edit something else in my ini, but what? And if not in the the registry? =/

              AppName: terran.icd AppVer: ModName: unknown
              ModVer: Offset: ff50f045

              AppName: terranx.icd AppVer: ModName: unknown
              ModVer: Offset: ff50f045

              AppName: terran.exe AppVer: ModName: unknown
              ModVer: Offset: ff50f045

              AppName: terranx.exe AppVer: ModName: unknown
              ModVer: Offset: ff50f045
              Veni Vidi Castravi Illegitimos


              • #22
                Fix found. I had Advanced Text Services turned on globally to allow me to type in Japanese in certain programs that wouldn't normally support Unicode. I had to manually disable that for these two programs. Once that was done, everything worked again.
                Veni Vidi Castravi Illegitimos