No announcement yet.

Terran.exe, XP problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Terran.exe, XP problem

    Hello everyone,

    I've got a problem running SMAC under WinXP home.
    After about 5 minutes or so, I get a message saying that terran.exe cause a problem and it crashes to desktop.

    I have the win2000&XP patch installed, I have changed the ini for cpu-support and I have installed the updatepatch v4.0. I have even set the compatibility mode to win98/me (it worked on my 98 machine).

    Is there anyone who can help me fix this?

    Tnx in advance,


  • #2
    goto the terran.txt file and search for a line that says forceoldalgorithm=0 and change that 0 to 1.

    It's something along those lines that i've seen people mention many times
    Learn to overcome the crass demands of flesh and bone, for they warp the matrix through which we perceive the world. Extend your awareness outward, beyond the self of body, to embrace the self of group and the self of humanity. The goals of the group and the greater race are transcendant, and to embrace them is to acheive enlightenment.


    • #3
      I couldn't find a terran.txt.
      I found a terran.exe and a terran.old, both of wich I can't edit.


      • #4
        Its alphacentauri.ini I think. Its a like a .txt

        But he already did that.

        1) The crappy metaspam is an affront to the true manner of the artform. - Dauphin
        That's like trying to overninja a ninja when you aren't a mammal. CAN'T BE DONE. - Kassi on doublecrossing Ljube-ljcvetko
        Check out the ALL NEW Galactic Overlord Website for v2.0 and the Napoleonic Overlord Website or even the Galactic Captians Website Thanks Geocities!
        Taht 'ventisular link be woo to clyck.


        • #5
          Yeah, I did that already.

          Nobody got an answer yet?
          Hmm, no problem, I'll wait


          • #6

            I believe I have a similar problem.

            I can play SMAC just fine, but cannot load SMAX without an error in TERRANX.ICD that causes a crash to the desktop. I have the Planetary Pack installed if that might matter.

            I can however *sometimes* load the game by running terranx.exe.

            I looked around for a terran.txt or .ini file and didn't find anything.

            Any suggestions??

            Last edited by ldkoehler; March 16, 2004, 20:23.


            • #7
              I am having similar problems too. I've tried everything and no luck. Alpha Centauri works just fine but no luck on Alien Crossfire.. I've tried loading it at 16 and 32 bit color depth too.. Here's a question? Could it be an issue with the NTFS file system?
              Just wondering whether everyone having problems is using NTFS and everyone who isn't can run it. OR Is everyone having problems running an AMD processor(like me.)


              • #8
                My game folder is on an NTFS drive. AMD processor.
                Have you tried getting a no-cd crack for it?
                Maybe that might be a factor. I just hate playing the cd-swapping game.
                I'm building a wagon! On some other part of the internets, obviously (but not that other site).


                • #9
                  The no CD crack fixed it.


                  • #10
                    I could install the game (smac and smax) fine on my desktop computer (athlon AMD processor) but on the laptop (P4) the game would only run SMAC.
                    I think I will try the nocd crack as well.
                    But I still think it has something to do with the processor.


                    • #11
                      Probably not the processor.. Your pentium laptop has the same problems my athlon had. Chipset maybe?


                      • #12
                        Hi ya'll,

                        I just came back and installed SMAC Planetary Pak on my computer. Forgotten how much I'd like this game. It may still be my favorite over anything that's come since.

                        I had a couple of install issues in getting it running on my XP Pro, Pentium 4 computer. But I was eventually successful.

                        When I first got the CPU message, I tried switching the compatability mode to Win98. That of course didn't fix it, and I found up on these boards the ForceOldAlgorithm setting.

                        I still got a problem after that, in that SMACX just stopped and died on startup. But then I went back and removed the compatability mode that I'd set.

                        Then it worked fine. So I my Toshiba laptop running XP Pro, it ran fine with the ForceOldAlgorithm bit set to 1 and no compatability modes set at all.

                        Hope that helps!
                        Forgotten just how good this game is!

                        Fear not the path of truth for the lack of others walking it.