No announcement yet.

SMACPP problems...

  • Filter
  • Time
  • Show
Clear All
new posts

  • SMACPP problems...

    Running Win98SE, using a DVD-ROM drive to run/play SMACPP [Sid Meier Alpha Centauri Planetary Pack] CD game. Have played this game many many many numerous times, even yesterday. Every night the PC gets shut down.

    Upon trying today to click the icon on desktop to load the game, which must run w/ the CD in the drive that it was originally loaded/installed from, the monitor goes to a grey screen, and then the PC locks up; totally locked, mouse is dead, all is lost... Control-Alt-Delete does nothing but give vent to frustration... After performing hard reboot, tried numerous times to play, even directly from the CD, each w/ the same grey screen result.

    Ran Norton Sys Diagnostics upon entire system = all came back good, except... CD-ROM that this game is in gives the "Error Reading Sector 1054 (0)" code. Ran same diagnostics upon only this CD-ROM, using other games Myst, etc.], all of these others came back good.

    The SMACPP CD has NOT been removed from the tray, it is not dirty, scratched, marred, etc. Even after cleaning it [for the heck of it], still getting same error code...

    So, after that long preamble: (a) why is this happening, (b) what does this code imply, and (c) is there any means to remedy this situation, so that can play this game, w/o any further lock-ups?

    Have tried looking at Symantics website for help; their Master Code list does not have a 1054, as it jumps from 1049 to 1100... grrrrr...

    I understand, however, that this code must imply that there is a bad sector upon this disk... but, how in blazes can a sector go bad, when the disk is not touched!

    What makes things even more interesting, is that now, when go to shut the computer down [after all is good, and back to "normal"], I get the "Fatal exception 0D has occured @ 00C7:BFF749B3. The current application will be terminated. blah blah... Press any key to contine". Well, you press any key, and nothing happens. All I can do is then reboot the computer... which brings me back to a "normal" desktop, and all other programs [besides SMAX] work just fine.

    Many thanks!

  • #2
    Try installing the no-cd patch (I run smac and smax without the disc both on my Sony P4 winXP desktop and my Dell winME laptop)

    You can get it here



    • #3
      Great! Thanks for the quick reply.

      Silly question... since I have both SMAC and SMAX, and am running the games currently from the SMACPP disc [which has both games], do I download the SMAC, the SMAX, or both patchs?

      I forgot that every great while that I will get a message saying something along the lines of "sorry, but we've encountered a teran.exe error, all is lost"... suppose this will fix that too... cool.

      - hobbes


      • #4
        I'm not sure about that. I do have the planetary pack.

        But I orginally had smac on my hard drive before that, so I only installed SMACX

        And the original smac I never needed a CD to run the game (just click ok on the box that comes up).

        What I've noticed is there are 2 different executables for smac and smacx. You probably only need the patch for smacx (replace the exe file with the one from the patch). You can double click the regular smac exe file and see if that works, if not, then download that no-cd patch as well.


        • #5
          Ok, silly question...

          I've got the SMAX downloaded into a "download" folder on my desktop... When I click on it, ZipGenius opens, and then I need to direct it to do what with this material - open? extract file? save it where?

          In other words, where and how does this downloaded material need to be and get there to properly do its stuff? Sorry, I know the previous post mentions to replace the current file w/ this downloaded version, but just desire to make sure its done right, so nothing else is compromised/damaged...


          • #6
            I assume you mean you have the SMACX no-cd patch downloaded (not the entire game).

            Just direct the .exe file to your smac folder.

            The default for me is: C:\Program Files\Firaxis Games\Sid Meier's Alpha Centauri

            It'll probably ask if you want to replace the existing file with the new file, say yes (although I always back mine up first- but it's not that important- worst comes to worst you just have to reinstall the game)


            • #7
              Hey it worked! Well, at least I can turn the computer off and back on, do reboots, etc. w/o any problems... haven't tried the game yet, as too busy w/ work, house, stuff, etc. Thanks to all for your help!!!