Announcement

Collapse

Welcome to the New Server!

Apolyton.net is now pointing to the new server. Please let us know if you spot any oddities or have any suggestions for what to add to the site!
See more
See less

APPCRASH when launching the Civ 5 DirectX10/11 exe

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • APPCRASH when launching the Civ 5 DirectX10/11 exe

    I ran a search on this without luck. I installed Steam & Civ 5 today and the DirectX 9 version loads, but I get an instant Application Crash when trying to run the DirectX 10/11 version. I have the latest version of DirectX 11, which I also reinstalled just to be sure the dlls were up to date.

    It's early still, but has anyone else run into this problem or do you have suggestions? I have tried turning off the opening movie in the UserSettings.ini file but that didn't help. The crash details are:

    Problem Event Name: APPCRASH
    Application Name: CivilizationV_DX11.exe
    Application Version: 1.0.0.7
    Application Timestamp: 4c92b5dd
    Fault Module Name: CivilizationV_DX11.exe
    Fault Module Version: 1.0.0.7
    Fault Module Timestamp: 4c92b5dd
    Exception Code: c0000005
    Exception Offset: 00406d4d
    OS Version: 6.1.7600.2.0.0.256.48
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    I'm running Win 7 Pro 64bit, 4 GB, IntelCore2 at 2.4GHz. My NVIDIA GeForce 7900GS has its latest drivers. Thanks in advance for any thoughts on this.
    One of these days I'll make 501 posts, and you won't have to look at my silly little diplomat anymore.
    "Oh my God, what a fabulous room. Are all these your guitars?"

  • #2
    How old is your graphics drivers?
    Do not fear, for I am with you; Do not anxiously look about you, for I am your God.-Isaiah 41:10
    I praise you because I am fearfully and wonderfully made - Psalms 139.14a
    Also active on WePlayCiv.

    Comment


    • #3
      Normally, I would ask whether DirectX 11 is installed on your computer, but Windows 7 comes with DirectX 11, doesn't it.

      -Martin
      Civ2 military advisor: "No complaints, Sir!"

      Comment


      • #4
        Yes I have DirectX11 and my GPU drivers are up-to-date. I checked NVIDIA's site today. The GPU drivers are 7/9/2010 and version 8.17.12.5896 if it helps.
        One of these days I'll make 501 posts, and you won't have to look at my silly little diplomat anymore.
        "Oh my God, what a fabulous room. Are all these your guitars?"

        Comment


        • #5
          The obvious things to attempt are ensuring you have the latest version of DirectX and video drivers. And if you have a steam download, verify the game cache (or re-download) because installs can occasionally be incomplete but unaware of it.

          But on a PC there are 1001 unanticipated hardware / OS settings that might cause problems. For some nvidia drivers, I've known turning Ambient Occlusion off on the control panel (even though according to nvidia it is always off except for games explicitly included in a list of theirs) to stop crashes. Or Aero frames in vista / win 7 (the 'glassy' window border style) has been known to cause crashes. Or out of date sound card drivers, unusual custom keyboard settings, or anything else really.

          If you update directx, video & sound drivers, and still have problems, then try unplugging any peripherals apart from very basic mouse and keyboard, disabling any unusual software, re-installing with anti-virus briefly disabled. If you can get it to work, then add other things back in one by one until you find which one causes the problem.

          Comment


          • #6
            Thanks, vulture. I'll give your suggestions a try. I know these things can be tricky to track down. I'll report back in case it's helpful to anyone running into the same thing. Thank goodness I can at least load the DirectX9 version so I'm not super annoyed
            One of these days I'll make 501 posts, and you won't have to look at my silly little diplomat anymore.
            "Oh my God, what a fabulous room. Are all these your guitars?"

            Comment


            • #7
              Try this: Go into "Documents/My Games/Sid Meier's Civilization 5/UserSettings.ini and change to the following:

              SkipIntroVideo = 1
              Do not fear, for I am with you; Do not anxiously look about you, for I am your God.-Isaiah 41:10
              I praise you because I am fearfully and wonderfully made - Psalms 139.14a
              Also active on WePlayCiv.

              Comment


              • #8
                Originally posted by Nikolai View Post
                Try this: Go into "Documents/My Games/Sid Meier's Civilization 5/UserSettings.ini and change to the following:

                SkipIntroVideo = 1
                Thanks, Nikolai, but I tried that before posting. A good method to try but it didn't help unfortunately.
                One of these days I'll make 501 posts, and you won't have to look at my silly little diplomat anymore.
                "Oh my God, what a fabulous room. Are all these your guitars?"

                Comment


                • #9
                  I would uninstall and reinstall your video card drivers. Sometimes they don't install properly and lead to weird crashes.
                  "The issue is there are still many people out there that use religion as a crutch for bigotry and hate. Like Ben."
                  Ben Kenobi: "That means I'm doing something right. "

                  Comment


                  • #10
                    Try disabling your antivirus. That might help too.
                    Do not fear, for I am with you; Do not anxiously look about you, for I am your God.-Isaiah 41:10
                    I praise you because I am fearfully and wonderfully made - Psalms 139.14a
                    Also active on WePlayCiv.

                    Comment


                    • #11
                      c0000005 as an exception code is an x86 access violation. It means the app or driver is trying to access memory it has not been allocated.

                      This could be an app error, or a driver error (video card or sound card most likely).

                      Theoretically it could also be antivirus, or anything that could interfere with how programs allocate memory.
                      "The issue is there are still many people out there that use religion as a crutch for bigotry and hate. Like Ben."
                      Ben Kenobi: "That means I'm doing something right. "

                      Comment


                      • #12
                        It crashes for me as well, if I chose to start civ that way, but after that it magically starts after all anyway!
                        Formerly known as "CyberShy"
                        Carpe Diem tamen Memento Mori

                        Comment


                        • #13
                          Antivirus disabled didn't help. I have also checked my sound card drivers, also up to date. I guess I will uninstall/reinstall drivers now.

                          Thanks for all the advice everyone! Keep it coming if you have more ideas
                          One of these days I'll make 501 posts, and you won't have to look at my silly little diplomat anymore.
                          "Oh my God, what a fabulous room. Are all these your guitars?"

                          Comment


                          • #14
                            I have two choices, directx is one of them, if I pick the other choice the game runs fine. You don't have this 2nd choice?
                            Formerly known as "CyberShy"
                            Carpe Diem tamen Memento Mori

                            Comment


                            • #15
                              Originally posted by Robert Plomp View Post
                              I have two choices, directx is one of them, if I pick the other choice the game runs fine. You don't have this 2nd choice?
                              Both choices are DirectX. DirectX 9 works, but the game is recommended on 11. It's what's crashing on me.
                              One of these days I'll make 501 posts, and you won't have to look at my silly little diplomat anymore.
                              "Oh my God, what a fabulous room. Are all these your guitars?"

                              Comment

                              Working...
                              X