Announcement

Collapse

Welcome to the New Server!

Apolyton.net is now pointing to the new server. Please let us know if you spot any oddities or have any suggestions for what to add to the site!
See more
See less

Civilization3.exe caused a divide error...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Civilization3.exe caused a divide error...

    I recieved this error upon capturing an Egpytian city in the early Medieval age. Any ideas as to what it could be?
    I captured another Egyptian city a few turns earlier which had settlers in it like this one. Right after I get the message "we have captured enemy units," and before the city screen pops up, the crash occurs.

    If you think it is the "divide by zero" error, please explain what this means and what can be done to correct it. I am playing with a modified bic file.

  • #2
    Could you attach the save, and if that bic is civ3mod.bic (and not scenario) it as well.
    Creator of the Civ3MultiTool

    Comment


    • #3
      Solution

      In Windows, Hit Ctrl-Alt-Del. Look for two things: "Ocraware" and "RealPlay". If you have either of these items, close them (End Task).

      Try the game again.

      If you do not have them, let me know.

      Comment


      • #4
        I am playing with the Medpack III bic that I have made. This crash occurs whenever I capture a size 1 city. I have captured 3 at different times, all belonging to the Egyptians. This bug does not appear when an AI captures a size 1 city.
        I am not running any new programs since my last game, and do not have either of the two problems Grapaslingo mentioned. This bug has mysteriously appeared since my last game.

        I have been playing the game for months now, and I have never been able to finish a game due to bugs since the patch came out.
        Between the bugs and the frustration from culture flipping, I have about decided to give up on the game.

        Comment


        • #5
          Originally posted by WesW
          I am playing with the Medpack III bic that I have made. This crash occurs whenever I capture a size 1 city. I have captured 3 at different times, all belonging to the Egyptians. This bug does not appear when an AI captures a size 1 city.
          I am not running any new programs since my last game, and do not have either of the two problems Grapaslingo mentioned. This bug has mysteriously appeared since my last game.

          I have been playing the game for months now, and I have never been able to finish a game due to bugs since the patch came out.
          Between the bugs and the frustration from culture flipping, I have about decided to give up on the game.
          That could be your problem. If you started the game before you installed the patch, some of the changes that were made at that time could be screwing up your game. Why don't you try playing it without the patch, and see if there's still a problem?

          Comment


          • #6
            I started another game, and got the same error at a seemingly random point. I think it has to do with file corruption from the autosave.

            Comment

            Working...
            X