No announcement yet.

FIXED! Screwed up fonts making things unreadable

  • Filter
  • Time
  • Show
Clear All
new posts

  • FIXED! Screwed up fonts making things unreadable

    For those of you with problems with a lot of the in game text being unreadable due to the fact its in the wrong spot, runs off the page, etc etc.

    First off, deleting your fonts until you get under 256, or whatever inforgrames/firaxis says won't fix the problem. It has nothing to do with the number of fonts. It has everything to do with another piece of software and Civ3 installing conflicting fonts.

    Goto your fonts folder. C:\windows\fonts or C:\winnt\fonts

    Look for fonts LucidaSans****. There may be quite a few. Delete them all. No need to delete all of the Lucida, just the ones with Sans in their name.

    Hopefully the game should look much better after this.

    This is only a workaround, not a fix. Because you deleted those fonts, some other software MAY look funny. Maybe with this info Firaxis can patch this sucker.

    I believe this is an issue with the font used in Civ3 and likely the naming/ID of it, and how it didn't get caught in QA is beyond me.

    ps I tested this on 4 different systems, and would appreciate other people findings.
    Last edited by Travathian; December 12, 2001, 18:35.

  • #2
    I haven't had a problem with my fonts - except for the funky population number post-patch - but i truly appreciate your diligent hardwork and troubleshooting.

    I'm actually slightly disgusted that Firaxis have been coming out with lame excuses and pseudo-solutions, whilst fans actually get to the nub of things.

    Still, can't help but wonder why the frig we have to delete fonts to accomodate CivIII.
    Orange and Tangerine Juice. More mellow than an orange, more orangy than a tangerine. It's alot like me, but without all the pulp.

    ~~ Shamelessly stolen from someone with talent.


    • #3
      Well if you did have the problem it makes diplomacy and the Civlopedia very difficult to use.

      Hasn't anyone else had this problem?


      • #4
        Thank you, thank you, thank you!!!

        Ever since I got the game I've been battling this problem -- with me it meant deleting a few more fonts every time I wanted to play! I was down to about 220 (from over 700!). Incredibly frustrating -- there goes another font down the drain -- wonder what that will mess up??

        Now in a few words you've fixed the problem and given me a clean, readable diplomacy screen every time I play! (I've reinstalled all 700 fonts, except the Lucida Sans's, and it works fine every time.)

        Did I say it before...?

        Thank you, thank you, thank you!!!


        Every time you win, remember: "The first shall be last".
        Every time you lose, remember: "The last shall be first".


        • #5
          Well you're welcome, glad to help.


          • #6
            I had the problem that my text would go off the bottom of the screen during diplomacy and trade. I've never been able to get it to work before, so I had very high hopes for your solution. There's just one problem. I have no main menu now . There are no entries on the main menu (where you would choose to start a new game, or load, etc.), just the background. Any ideas?

            I just realized you might want to know which fonts I had and deleted.

            I'm sure there's someone out there with this problem, and hopefully someone who's figured it out.


            • #7
              Reinstall. Then it should only put the Civ3 fonts in there. If that doesn't work, try replacing each one of those fonts one by one, testing the game between each. If that still doesn't work, keep harassing technical support and refer them to this post. Good luck.

              Trust me, its a much better game when you can actually read all of the text! Don't give up!


              • #8

                Travathian, my brother and I truly love you. You are indeed fit to rule a Civilization to Stand the Test of Time.

                Who'd have thought it would be something so simple?

                We'd send you a Christmas Card, but we don't have your address, and I wouldn't recommned posting your address on the message board....


                • #9
                  Save your money on the cards, just send me cash thru paypal, lol.

                  I'm curious to know, for those who had this work, if you ever identified the software that installed the other fonts?

                  For me it was some A+ certification testing software.


                  • #10

                    Well done! I hope you have sent this fix to Infogrames themselves, as they need to fix this prob quickly. It has been a hassle with everyone I know of.

                    What a pain that they release a game knowing it has bugs (did you get a look at the huge list of things the 1.16f patch fixes? Don't tell me they weren't writing that as the game was being packaged and shipped!).

                    A great game, but very disappointing in it bugs. I will not be so eager to get the next one!

                    Anyway, you have made my MillenniuM! Thanks!


                    • #11
                      You all could always write to Firaxis and ask to make me a beta tester!

                      I'm glad this has helped people, I know it made a huge difference for me playing the game properly. And since the patch didn't fix it, I damn near gave up on the game! Spread the word!


                      • #12
                        I sent a link to your solution to Firaxis, strongly suggesting they take a look and and fix the problem in another patch before all other players of the game go mad like we nearly did!
                        So, it may be a good time to register your interest as a beta tester!


                        • #13
                          They do listen!!!

                          Thought you all would like to know that I recevied a reply from Firaxis about two minutes after I sent a link to this excellent bug fix.

                          Here 'tis. Again, well done Travathian!!

                          Awesome. I will.

                          ----- Original Message -----
                          From: "Craig Pickering"
                          Sent: Wednesday, January 09, 2002 7:52 PM
                          Subject: Bug Report: CIVIII

                          > BUG REPORT for CIVIII follows:
                          > -------------------------------------------------------
                          > Many people have has a problem with the writing in Civ3, especially in
                          diplomacy screens where some is not visible at all (it disappears down the
                          bottom of the page instead of appearing in the appropriate box), plus
                          over-writing in many Civilopedia entries.
                          > One genius has found a fix, which has prevented many fans (myself
                          included) from giving up on the game entirely (yes, it was that bad!).
                          > Please go to the link below for the solution, and for the overwhelming
                          reaction to it.
                          > I suggest you include it in your next patch, or countless others will give
                          up like I nearly did.
                          > Regards,
                          > Craig


                          • #14
                            I guess we'll see if they include it in this next patch. Be nice to not have to delete fonts I may actually need.


                            • #15
                              another font-related problem

                              I don't know whether this is related, but I had a problem with the font in the Load/Save Game dialog. It was too large, and consequently, the year of the save was not displayed for the Babylon civ--it ran off the right edge.

                              I solved this by changing "MainFontSize=16" to "ainFontSize=15" in the civilization3.ini file.

                              Oddly, I haven't experienced the other problem, despite a ton of Lucida Sans fonts in my Fonts folder.