Announcement

Collapse
No announcement yet.

Civ2 ai broken

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Civ2 ai broken

    Even after twenty years of playing the game I still enjoy the occasional Civ2 session. However, recently I noticed the AI pathfinding gets destroyed by Windows 10. I am pretty sure it didn't behave like that under Windows 7. I have played the standard scenarios, Rome and WWII, dozens if not hundreds of times and since Windows 10 I noticed the AI behaviour has changed dramatically. I've seen AI units aimlessly going back and forth being stuck in some kind of loop. This becomes even more insane if somehow they manage rail roads or get on mine. Since movement points on rail road cost 0, it looks really weird at the least. What's more important than the looks, is the actual game play; ruined. Anyone else have this problem and is there a way to fix it?
    I'm playing the Multiplayer Gold installation. I have the original cd's (Civ 2 and Civ 2 Scenarios) and the collected edition Civilization Chronicles (which also includes Civ 2 Fantastic Worlds and Test of Time).

  • #2
    How can you get Civ2 to run in Win10 ? My Win10 and Win_8.1 machines simply refuse to play, even in Win7 or WinXP emulation mode...

    Comment


    • #3
      Yes, there was something I had to do with some video setting. The installation failed because it didn't recognise the outdated video player or something. I just googled it and found the solution eventually. I can't remember from the top of my head what it was. You had to disable something I think

      Comment

      Working...
      X