No announcement yet.

Need help with frustrating error message

  • Filter
  • Time
  • Show
Clear All
new posts

  • Need help with frustrating error message

    Hey there all!!

    I'm back again with a very frustrating problem that is making CTP2 impossible to play. I had some problems with MODSwapper and my installed MOD's so I uninstalled everything and made an absolutely clean reinstall of CTP2 and the 1.2 patch. Everything works fine and I can play a new game for any length of time with no problems, but... I cannot reload ANY saved game. If I play for awhile, save the game and then go to reload it it works... until I try to move any unit or select any city. The program cuts out to the Windows desktop and I get the following error message:

    In_ObjectCheckForUnit_Function_GetUnitFromArmyValu e Out of Bounds

    Has anyone come across this before and is there a solution? I never had this problem before and I figured with a clean install and no MODs... what could be going wrong?

    I sure would appreciate any help from you great CTP'ers


  • #2
    The function "CheckForUnit" is used in the tutorial. Is that the level you're playing on?


    • #3
      Hey there, Peter!

      Thanks for the quick response...

      That is what I forgot to include in my post (as well as noticing my typo... it's the 1.1 patch... Activision never got around to anything further)... The first game I was trying to load was on Hard level. I then tried saving and loading everying from Impossible on down to Beginner and am getting the same error upon loading any of these.




      • #4
        Hey there!

        What you said about the CheckForUnit command being used by the tutorial sparked a glmmer so I went back and checked something I didn't notice at the time... When I was playing each level for a few turns, saving, and then reloading I had not noticed that on the Beginner and Easy level I was not getting any tutorial messages. I went back in and tried both a new Beginner and Easy game... no tutorial messages. I went into the gameplay options and the tutorial help was set ON, but no messages were appearing. I tried turning the option to OFF, restarted CTP and then switch to ON again, but still no messages and the same error on reloading games of ANY level up to Impossible.

        I figured something must be pretty screwed up, so I did f full uninstall/reinstall again and VOILA!! Back and running. Tutorial messages working on the baby levels and I can reload my saved Hard+ games.

        Thank you SO much for pointing my brain in the right direction. :-)



        • #5
          Glad it helped. Actually, I was thinking that you'd uncovered some kind of savegame bug in the tutorial script.