No announcement yet.

HELP! (Bmp2ctp2)

  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP! (Bmp2ctp2)

    Can somebody tell me why I can't import a txt map?
    I set the correct map sizes in Const.txt, but everytime I try to
    load a txt, the game kicks me out.

  • #2
    define kicks you out? how big a map are you using? are you sure your const.txt matches the map size? does it freeze up? do you have the update installed? what other changes to your files have you made?

    Just a few questions

    BMP2CTP2 friend to all =)


    • #3
      I installed the official activision patch, along with the new apolyton patch. The only thing I changed was the one line in const.txt. When I try to import the map in ctp2, it shows up in the load window, but when I click it the game closes and leaves at the windows desktop. I tried the /import map.txt in the chatbox but it doesn't do anything. Any ideas you might have would be appreciated!


      • #4
        Hmmm... the problem with loading a map could be that your system setup wasn't similar enough to the makers... there are occassionally problems that way. The problem with the import map.txt is that you have to have the txt file in the main CTP2_program directory.... if you export a map from CTP2 and then find where it ends up, just put the txt map you want to import in the same directory. Other than that I don't know. It works for everyone else, why are you sooooo special


        • #5
          OK, I reloaded CTP2, and all the patches. The import function still doesn't do anything, so I tried moving the txt file to the save\maps directory. It now shows that it can be loaded, but now instead of the game crashing, I get an 'Unexpected End of File' error. Right now I'm limiting myself to the original map sizes. I think thats why I got the error instead of the program crash. But it still doesn't work.

          BTW, are you the same Omnigod that made that incredible sized world map? If so, I think it is great (if I can ever get the import working), but what are all those blocky black squares?


          • #6
            Okay... the import map function for txt, the file must be in the CTP2_program folder not the save game folder... next time your playing with the editor, type /exportmap test.txt. Look for that files exported location and put your map in there. Then go back to the editor and /importmap yourmap.txt. That should work, it works for me, and I believe that's how it's designed to work.

            Yes I am the OmniGod that created the reallllllly big map. The little black blocky things are guildlines for some of the major rivers in the world. I couldn't get a good thin lined map that would do what I wanted, especially when you go to lower resolution, so I added the little blocky lines as the guidelines to the rivers, it reallly helps if you're looking for accuracy of the rivers in certain areas. There were some problems especially with lining the map up properly and may result in a river tile in the shallow water area, but for the most part it works pretty well...

            Time to go check out CIV III... see if I can play there for awhile =)