Results 1 to 3 of 3

Thread: Error 1706 problem when patching 1.74

  1. #1
    mypulitzer
    Settler
    Join Date
    18 Dec 2007
    Posts
    2
    Country
    This is mypulitzer's Country Flag
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Local Date
    December 23, 2014
    Local Time
    05:08

    Error 1706 problem when patching 1.74

    Hello everyone,

    I'm new here, and I have a problem. I've searched far and wide on both this site's forums and the forums at civfanatics (as well as numerous google searches that have lead to other sites) to find a definitive fix for the "Error 1706" I've been receiving when patching Civ IV 1.61 to 1.74. In case you haven't seen the other posts concerning this error, it reads:

    "Product: Sid Meier's Civilization 4 -- Error 1706.No valid source could be found for product Sid Meier's Civilization 4. The Windows Installer cannot continue."

    I've tried numerous fixes, including Petek's here http://apolyton.net/forums/showthrea...0&pagenumber=1 and I've read through monkeydoo's "How I fixed error 1706...etc."post - none have worked. I have the latest DX9 packages installed and I'm running Winxp with the GOTY edition of Civ IV.

    After receiving this error, I have tried to play and everything seems fine, but I just can't help but want to rid myself of the patching error. It doesn't seem right that it keeps happening no matter what I try, and that the Civ IV developers wouldn't do something to fix it, since I've seen it occurring to many more people than just myself. Please, any help is appreciated...I want to discover a fix that works for everyone.

    Thank you.

  2. #2
    Kuciwalker
    Deity Kuciwalker's Avatar
    Join Date
    17 Feb 2001
    Posts
    19,467
    Thanks
    9
    Thanked 22 Times in 17 Posts
    Local Date
    December 23, 2014
    Local Time
    00:08
    civfanatics


    Just for mentioning this no one here will help you



    Unfortunately, reading through Petek's thread it seems they've suggested everything I would...

    Hopefully a developer sees this thread.

  3. #3
    mypulitzer
    Settler
    Join Date
    18 Dec 2007
    Posts
    2
    Country
    This is mypulitzer's Country Flag
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Local Date
    December 23, 2014
    Local Time
    05:08
    Originally posted by Kuciwalker
    civfanatics


    Just for mentioning this no one here will help you



    Unfortunately, reading through Petek's thread it seems they've suggested everything I would...

    Hopefully a developer sees this thread.
    sorry for mentioning the name...I just wanted to make the point that I've looked nearly everywhere I could possibly look.

    Thanks anyways.

Similar Threads

  1. Replies: 1
    Last Post: December 17, 2007, 14:14
  2. Error 1706? anyone else get this?
    By GodScythe in forum Civilization IV General
    Replies: 18
    Last Post: March 23, 2006, 17:14
  3. Patching problem
    By alrux in forum Rise of Nations
    Replies: 0
    Last Post: May 31, 2003, 17:48
  4. CIV EXE.ERROR crashing problem
    By Bilas in forum Civilization III
    Replies: 1
    Last Post: March 6, 2002, 18:00
  5. Patching problem !!! plz help !
    By Louis Cyr in forum CtP2-General/Help/Strategy/Multiplaying-Archive
    Replies: 2
    Last Post: December 15, 2000, 06:25

Bookmarks

Posting Permissions