No announcement yet.

How to get Call to Power 1 to run? (win7)

  • Filter
  • Time
  • Show
Clear All
new posts

  • How to get Call to Power 1 to run? (win7)

    Main problem :
    game starts... hear sound.. but no intro video.
    -took all files out of video's folder game now starts into the starting menu... but after a couple seconds (about 3) the game freezes...
    (I tried and if quick I can press buttons in the first few seconds... it seems to make no difference if I move my mouse really fast, not move the mouse or press quickly trough the buttons... it freezes a few seconds in)

    how to fix this so I can enjoy the memories of the space layer once more)

    I obtained the game from myabandonedware as my fysical disk of the game has been lost in the long gone past and well if it is on there it is legal to download not?
    (and while I would buy it on GoG it aint on there)

    -> the 1.2 fix seems not to work with their multilanguage CD 3.4gb version.. so I just picked the 500MB-ish ISO version.
    -> I also installed WinISO to be able to mount and install it.

    While I messed up with the compability mode install... I deinstalled and reinstalled under admin rights and with win98 compability.
    I did a full install.
    -I applied the 1.2 and the 1.21 fix
    **game still did start black screen and than froze (had to close it in process manager)
    **removed all video files
    **game did boot to start menu, but frooze a couple seconds in...

    if anybody can help me out that be sweet...

    Since you need system specs to help me :
    I run windows 7 Professional 64Bits
    on a 5960x cpu
    128GB of 2800Mhz C14 ram
    and a RTX 2080ti

  • #2
    the problem is that when you try to run the game on 64bit windows, it looks for the dlls to play the video in the wrong folder. Syswow64 instead of System32. just copy the files starting from ir32_32.dll to iri.dll from System32 to Syswow64. Then run the combined community codec and either install the codecs or deselect them. At the end simply select "Reset all Settings" and click next and follow until you can exit. It works from XP64bit to Windows 11. Works for CTP2 also.