Announcement

Collapse
No announcement yet.

Another key problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Another key problem

    So, lately my keyboards (both at home and at work) on Vista is acting quite annoying at some times. My guess is that I accidentally press a key shortcut that I haven't been able to replicate (when trying to revert back to normal)

    The problem:
    Every time I press a key it acts as if ctrl is pressed, which means that instead of writing letters it activates a lot of shortcuts (like opening save dialog box when pressing 's')

    What is the shortcut key to revert it back to normal?

    I have noticed that the problem often occour when writing drive letters (like D:\), so often when installing games (which are always installed on D) the problem occours. Unfortunately hitting the same key sequense doesn't fix the problem

    This problem started when I reinstalled Vista a month ago (same time I installed SP1 for the first time). I had been using Vista ever since release, never seen this problem before
    This space is empty... or is it?

  • #2
    I suppose you might have the 'accessibility' option turned on (on XP at least, if you hold down shift or ctrl or alt for ~8 seconds, it will stick). That's in the Accessibility control panel.

    Also, it could be the normal keyboard conflict (I never have learned if this is hardware or software, or somewhere in between). It happens to me periodically (like once every few months), and the only way to fix it is to mash the shift/ctrl/alt keys a few times...

    If it's a consistent key combo, I'd wonder if there is an issue with the keys being on the same circuit... keyboards are funny in that several keys 'share' a circuit, and it's not impossible that shift D and : might share a circuit... or, perhaps you accidentally hit ctrl fairly often when in this combo (with : so close to the right shift key, I could see that being accidental) and something causes it to stick (probably because your keyboard can't handle so many keypresses at once - 3 is usually the max for many keyboards).

    You might try cleaning out the keyboard's contact circuits, though if it's on two computers at once that's unlikely.

    All of this is just random speculation though (and probably not even correct in parts) ...
    Last edited by snoopy369; October 16, 2008, 10:27.
    <Reverend> IRC is just multiplayer notepad.
    I like your SNOOPY POSTER! - While you Wait quote.

    Comment


    • #3
      accessibility is turned off, that was the first I checked

      Hitting shift+ctrl+alt a few times at the same time fixed the problem 3 out of the 4 tries I just made. Thanks

      It doesn't seem to be a keyboard problem, as it happens on two completely different keyboards
      This space is empty... or is it?

      Comment


      • #4
        It's happened to me on almost every keyboard I've owned, at one time or another ... I suspect it's a 'keyboard' problem that is innate to how keyboards are designed (they nearly all have the same circuit layout). Probably D:\ are on some circuit together in some way that breaks things...
        <Reverend> IRC is just multiplayer notepad.
        I like your SNOOPY POSTER! - While you Wait quote.

        Comment

        Working...
        X