Announcement

Collapse
No announcement yet.

UTILITY: Civ3MultiTool v1.12.5 (C3MT) - Unofficial Civ 3 editor (fourth thread)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I have been trying to get the save game editor to work and all it will do is crash. I get these error messages when I load it

    Error: Object variable or With block variable not set (91) in C3MT::frmSaveEdit.frm Line 3493
    SGE: Making Mapsummary
    Error: Object variable or With block variable not set (91) in C3MT::frmSaveEdit.frm Line 3501
    Error: Object variable or With block variable not set (91) in C3MT::frmSaveEdit.frm Line 3508

    After which it seems to work except if I try to use the filter it crashes or if I try to save it crashes. I just tried redownloading it from here but it still did the same thing. What's going wrong and how can I fix it?
    It is easier to be insane and know for sure that you are insane that to be sane and not sure if you are.

    Comment


    • Seems as if your save fails to load. Could you post it?
      Creator of the Civ3MultiTool

      Comment


      • Ok, but I'm not exactly sure what you want me to post ... do you mean attach the saved game to a message? If so, I can do that no problem, if not then I guess this old brain needs to have what you want explained in simple words [heh]
        It is easier to be insane and know for sure that you are insane that to be sane and not sure if you are.

        Comment


        • if it's small ennough to attach then do so. Otherwise use the upload feature.
          Creator of the Civ3MultiTool

          Comment


          • Ok, I've uploaded the save file ... but I'm afraid I'm very new to this board and so I don't know the ins and outs of it yet and I'm not sure how to do a link to the file so you can get it.
            It is easier to be insane and know for sure that you are insane that to be sane and not sure if you are.

            Comment


            • Never mind - I found the answer to my question [I think] now if I have this right, then this should link the file:

              http://apolyton.net/upload/view.php?...nese1772AD.SAV
              It is easier to be insane and know for sure that you are insane that to be sane and not sure if you are.

              Comment


              • The last time I played Civ3PTW?... a year or so.

                I tried the lastest version, 1.11.5 (full install version) and I use PTW (1.27f).

                Unfortunatly, when I try to load a PTW save file, it says [ Not a Civ 3] and it crashes. Also, the default laod save games directory is located in Civ3 and not PTW.

                PTW is working fine though. It seems Civ3MultiTool doesn't see it installed. I can't see why!

                Here is the log file:

                STARTUP: 2005-06-02 04:46:10
                STARTUP: C:\Program Files\C3MT\::1.11.5
                STARTUP: arguments:
                STARTUP: logfile C:\Program Files\C3MT\s2.log
                STARTUP: MainThread: 2484
                STARTUP: Running on Windows XP
                STARTUP: Loading splashscreen...
                STARTUP: Checking for new version...
                STARTUP: Loading registrysettings...
                STARTUP: Read settings...
                SETTINGS: Loading language settings.
                STARTUP: Loading language file.
                LANGUAGE: Loading c3mt.txt
                LANGUAGE: Fullpath: C:\Program Files\C3MT\c3mt.txt
                SETTINGS: Loading old C3CT settings.
                SETTINGS: Deleting old C3CT settings.
                SETTINGS: Loading C3MT settings.
                SETTINGS: Loading old C3CT user specific settings.
                SETTINGS: Loading C3MT user specific settings.
                STARTUP: Get paths...
                STARTUP: System directory: C:\WINDOWS\System32
                STARTUP: Testing DLL usability...
                STARTUP: Usability test pass 1 - successful
                STARTUP: Usability test pass 2 - successful
                Civ3path: C:\Jeux\Civs\Civ3\
                PTW not installed.
                Conquest not installed.
                STARTUP: Usability test pass 3 - successful
                STARTUP: Checking CDD-association
                STARTUP: Checking CDD-association
                STARTUP: Checking for undeleted logfiles (crashed seesions)...
                STARTUP: Connected to host... Sending request
                STARTUP: Newest version: 1.11.5
                STARTUP: Download location: http://apolyton.net/forums/showthrea...hreadid=100445
                STARTUP: Location name: Apolyton CS Forums
                STARTUP: Extra versioninfo: New in v1.11.5: Bugfix release with improved error tracking.\n\nNew in version 1.11:\nRewritten save- and scenario-handling system\nImage2Map - Convert PCX images to Civ3 maps\nImproved C3C support
                STARTUP: Finding Civ3 version...
                STARTUP: Civ3 version: 1,29
                STARTUP: Handing command line options
                SGE: Loading...
                SGE: Applying overrides...
                SGE: Resetting timescale...
                SGE: Prepering tabs...
                SGE: Setting initial loading directory...
                SGE: Disabling controls...
                SGE: Resetting filters...
                SGE: Loading palettes...
                SAVELOAD: loading C:\Jeux\Civs\Civ3\CIV3PTW\Saves\Azulade\1.sav
                SAVELOAD: opening/decompressing and opening save
                Opening C:\Jeux\Civs\Civ3\CIV3PTW\Saves\Azulade\1.sav
                SAVELOAD: Loading Default Rules
                Error: Subscript out of range (9) in C3MT::StreamBuffer.cls Line 710
                SAVELOAD: A parse error occured
                BICGET: Loading Version (VER#)
                BICGET: Version is 11,19
                BICGET: Found BIC Section: BLDG

                I tried to install and uninstall C3mt several times.

                Comment


                • Can someone post me the registry content of both PTW and C3MT? So I can compare them and see if there is anything wrong with mine.

                  Comment


                  • C3MT registry content isn't that important. Just settings.

                    PTW should have an install_path somehere pointing to the civ3ptw directory
                    Creator of the Civ3MultiTool

                    Comment


                    • v1.11.6

                      1.11.6
                      - Added code to eliminate (hopefully) runtime errors due to fail in save load.
                      - Improved error logging in more areas of the code (still not all)
                      - Corrected a subscriptout of range error whan using filter with non-embeded rules.
                      - Removed section searching from GAME datasection in saveload. (This should eliminate some rare cases of files not loading properly due to garbage strings lookingas section tags)
                      - Corrected adivision by zero error that could occur if a save was loaded on turn 1.
                      - Corrected some backward compabilities with old BI*-versions. (Some values got initiated to invalid values, which could cause the tool to crash with division by zero error)
                      - Corrected bug in serialization of zerolength areas that sometimes would cause DataIO save corruptions.
                      - Corrected bug in backwardbompability saving of save headers.
                      - Updated Map import to work with the new save handling code.


                      download
                      Creator of the Civ3MultiTool

                      Comment


                      • I have a saved game that hangs on the next turn, and I cannot figure out why. When I use the SGE, when I go to the cities tab, and choose a particular city, I get a "Runtime Error '13'" Type mismatch. Its a city that recently was captured by another civ.... can you tell me what this runtime error represents? I'd like to figure out how to salvage this savegame.

                        Thanks.
                        Question Authority.......with mime...

                        Comment


                        • that error most likely mean that some variable fails to be loaded. Either due to unknown information, or an error in the save.
                          Creator of the Civ3MultiTool

                          Comment


                          • Hi!
                            Just bought Civ3 (yep a slowpoke) and thought I try your tool also but unfortunately I immediately run into problems. I am running verson 1.11.6 under windows XP.

                            Trying to export a map I get:
                            Error: Object variable or With block variable not set (91) in C3MT::SAVE_Map_Tile.cls Line 220

                            This is a fatal error as in locking the program

                            Trying to save a change (or even an unchanged file) gives
                            Path/File access error 75 streambuffer.cls line 833
                            and trying to start a saved file (after ignoring) gives me Data IO operation error PALV.

                            Comment


                            • I don't know what the tool supports, but do get to the latest patch:

                              1.29 for Civ3
                              1.27 for PTW
                              1.22 for C3C

                              Comment


                              • Like vmxa said the chances that later patches work are higher than the chances that earlier does. The backward compability code really neeeds some attecntion.
                                Creator of the Civ3MultiTool

                                Comment

                                Working...
                                X