Announcement

Collapse

Welcome to the New Server!

Apolyton.net is now pointing to the new server. Please let us know if you spot any oddities or have any suggestions for what to add to the site!
See more
See less

UTILITY: Civ3MultiTool v1.12.5 (C3MT) - Unofficial Civ 3 editor (fourth thread)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Check your session log, and see if it identifies the Civ3 paths correctly. (The tool should load them from the registry)

    It may be that CIVIII Complete use different registry keys than installing the differents parts separeate.
    Creator of the Civ3MultiTool

    Comment


    • I've been trying to use the SaveGame Modifier, but it seems to wind up corrupting any file that I save using the modifier. Even if I make no changes to the .sav file, but just save it using C3MT, I get problems. I've tried it on a variety of .sav files, but always get the same problem. When I try to load the game in Civ3, I get the error message: "Data IO operation system error: BIC"

      Also, if I try to load the files that I save using the modifier in C3MT itself, I get "Error while listing races: object variable or With variable not set" and then "Error while listing civs: object variable or With variable not set"

      I'm using Civ 3 with the 1.29f_US patch.

      Any help? Thanks!

      Comment


      • It does find the right folders. Maybe you can see something in the file that I cant.

        I have tried reinstalling both the Multi-tool and CIV3 Complete.

        Also, I have yet to find a trainer that works. So there must be something funky with this version. If anyone knows of a trainer that works with CIV III Complete, please let me know.
        Attached Files

        Comment


        • The problem is "STARTUP: Vanilla Civ3 not installed!"

          If you can tell me where the CIV3 complete registry key Install_Path is stored I can have it fixed in the next version.
          Vanilla Cv3 is in
          HKEY_LOCAL_MACHINE\SOFTWARE\Infogrames Interactive\Civilization III
          and PTW and C3C is in
          HKEY_LOCAL_MACHINE\SOFTWARE\Infogrames\*
          Could you see if there is any info about complete somewhere around there?
          Creator of the Civ3MultiTool

          Comment


          • Key Name: HKEY_LOCAL_MACHINE\SOFTWARE\Atari\Civilization III - Complete Edition
            Value 1
            Name: INSTALL_PATH
            Type: REG_SZ
            Data: C:\Program Files\Atari\Civilization III Complete\

            ===============
            Key Name: HKEY_LOCAL_MACHINE\SOFTWARE\Infogrames\Civ3PTW

            Value 3
            Name: Install_Path
            Type: REG_SZ
            Data: C:\Program Files\Atari\Civilization III Complete\Civ3PTW

            ===============
            Key Name: HKEY_LOCAL_MACHINE\SOFTWARE\Infogrames\Conquests

            Value 2
            Name: Install_Path
            Type: REG_SZ
            Data: C:\Program Files\Atari\Civilization III Complete\Conquests


            I hope this helps

            EDIT: I have attached all of the reg keys I could find with Install_Path in it.
            Attached Files

            Comment


            • doesnt work

              bha this tool doesnt work at all wrong
              when creating a unit and loading the .SAV i get an IO adress error
              when like adding an improvement such as a grenier i get a runtime 438 error

              i have civ3 ptw and all patches, so i say wtf is going
              let me tell ya this is poor job, everything i do i get an error message

              Comment


              • In that case, why don't you create your own editor. I don't have time to maintain this anyways. Get v1.10.x it should work with PTW, but were totally unmaintainable. The 1.11.x branch has lots of new code that still isn't trimmed in yet. Most of the code changes in that brance is to open up for continuued development and hopefully make it possible to create a version working with at least the three last patches of each version. However the fact that I don't have time for more than very small tests myself results in some bugs taking long time to fix. Generally I don't have time to try to reproduce bugs any more The times when session logs give me a hint of what goes wrong I may make a change other times I just try to figure what area of the code that are most likely to cause the bug and mplement more error handling. v1.11.5 will have mush more refined error messages in several parts of the utility as a result of a codupgrade related to another tool I'm working with.

                Also note that the currently not very well working SGE only is a part of this multi tool. The parts of the tool aimed at scenario design is more stable, and also easier to maintain.

                v1.11.5 is on it's way out. I've built it and am waiting for Settler III to allow me to upload it. I wouldn't think it will fix incompability wit certain combinations of Languages OSes and patch versions but it will probably give more useful errormessage that can be used to track some of those bugs down
                Creator of the Civ3MultiTool

                Comment


                • Erekose, if you don’t have anything useful to say, please keep it to yourself.
                  "Me Fail English? That's Unpossible!"

                  Gramphos, I really appreciate all the hard work you’ve put into this tool and the effort you’ve put into helping me get the Multi-tool working with my version.

                  Comment


                  • erekose that is surely not the way to get assistance. You could have try a little restraint.

                    I mean it did not cost you anything to acquire the tool, so why complain?

                    Comment


                    • v1.11.5 - now at Apolyton

                      This version has been out for a few days posted at CFC during the early days of Settler III. Now it's also uploaded on Polly and the version-check info should be updated as well.

                      1.11.5
                      - Fixed adding multiple units with the UCW
                      - Fixed Import/Export functionality for units in the CT
                      - Errorlogging improved in varius areas of the code.
                      - The tool should now identify Civilization III Complete installations
                      - Added description to Image<->Map converter entry on main menu


                      v1.11.5 comes either as a full installer or as a small patch against v1.x. patch | install



                      Please not that even if a bug you have reported earlier haven't been fixed in this version, you should report it again. The improved errorhandling and logging will make bugtracking a lot easier for me if eveything goes as planned.
                      Creator of the Civ3MultiTool

                      Comment


                      • I can't seem to use the Unit Settings (Global) feature of the saved game editor at all. The drop down box and the stats just wont change. And I did try checking Enabled Unfinished Features option from the main MultiTool Settings.

                        Haplo

                        Comment


                        • I'm still getting "File not found: Art\Units\palettes\ntp00.pcx" error. All the way to ntp31.pcx

                          Then it crashes.

                          STARTUP: 2005-05-19 18:50:53
                          STARTUP: C:\Program Files\Atari\Civilization III Complete\3Cmt\::1.11.5
                          STARTUP: arguments:
                          STARTUP: logfile C:\Program Files\Atari\Civilization III Complete\3Cmt\s44.log
                          STARTUP: MainThread: 2852
                          STARTUP: Running on Windows XP Service Pack 1
                          STARTUP: Loading splashscreen...
                          STARTUP: Loading registrysettings...
                          STARTUP: Read settings...
                          SETTINGS: Loading language settings.
                          STARTUP: Loading language file.
                          LANGUAGE: Loading c3mt.txt
                          LANGUAGE: Fullpath: C:\Program Files\Atari\Civilization III Complete\3Cmt\c3mt.txt
                          SETTINGS: Loading old C3CT settings.
                          SETTINGS: Deleting old C3CT settings.
                          SETTINGS: Loading C3MT settings.
                          SETTINGS: Loading old C3CT user specific settings.
                          SETTINGS: Loading C3MT user specific settings.
                          STARTUP: Get paths...
                          STARTUP: System directory: C:\WINDOWS\System32
                          STARTUP: Testing DLL usability...
                          STARTUP: Usability test pass 1 - successful
                          STARTUP: Usability test pass 2 - successful
                          Vanilla Civ3 not installed!
                          PTWpath: C:\Program Files\Atari\Civilization III Complete\Civ3PTW\
                          C3Cpath: C:\Program Files\Atari\Civilization III Complete\Conquests\
                          STARTUP: Usability test pass 3 - successful
                          STARTUP: Checking CDD-association
                          STARTUP: Checking CDD-association
                          STARTUP: Finding Civ3 version...
                          STARTUP: FAIL: (0)
                          STARTUP: Load taking long time... Trying to speed up.
                          SGE: Loading...
                          SGE: Applying overrides...
                          SGE: Resetting timescale...
                          SGE: Prepering tabs...
                          SGE: Setting initial loading directory...
                          SGE: Disabling controls...
                          SGE: Resetting filters...
                          SGE: Loading palettes...
                          Attached Files

                          Comment


                          • Might have the wrong file uploaded.

                            I just dl'ed 1.11.5 (full) and here is the c3mt.log;


                            Upgrade to version 1.11.4
                            ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ
                            Invalid procedure call or argument(5) at Startup
                            Error: Invalid property value(380)3/13/2005 9:23:19 AM in lslLEAD_Click
                            Invalid procedure call or argument(5) at Startup
                            Error: Invalid property value(380)3/19/2005 9:27:57 PM in lslLEAD_Click
                            Bad file name or number(52) at Startup

                            Then the same errors as already posted.

                            Comment


                            • After spitting the errors, it seemed to loadand save a Conquests save game fine.

                              All the spash screens say 1.11.5

                              I knew after that screwy setup, that Complete was a waste.....lmfao

                              damn them.

                              Comment


                              • Do you get a session log?
                                Creator of the Civ3MultiTool

                                Comment

                                Working...
                                X