Announcement

Collapse
No announcement yet.

Failed to allocate video memory. Please try reducing your graphics settings.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed to allocate video memory. Please try reducing your graphics settings.

    Running WinXP, 1.6Ghz Pentium M, NVIDIA GeForce Go5200, 1.5 GB Ram plus 1.2 GB page allocation, DirectX 9c

    Installed Civ4 v 1.09 from disc (boxed copy)
    Installed 1.61 patch

    Now at startup I get the message
    Failed to allocate video memory. Please try reducing your graphics settings.
    File:\Source\main\Civilization4\SDKs\Gamebryo2_0.. .

    Initial installation works fine, but after the patch the game wont start.

    I've tried the following (after sifting through innumerable suggestions on various blogs):
    -Alter the .ini file (hideMinSpec and fullScreen options)
    -Clear the cache files from the user dir
    -Install latest video card drivers
    -Reinstall game, patch and directx
    -Use the UnPack utiltity on the Asset1, Asset2 Asset3 etc files

    None of the proposed solutions (anywhere) seem to work - grrr.

    Removing entire install and reinstalling the 1.09 version lets me play again... (something slipped thru regression testing me-thinks)

    Anyone know of a 'real' solution to this problem?

    If not, does anyone know when a patch will come out from Firaxis that would fix this ?

    Cheers.

  • #2
    How much VRAM do you have? Go to the start menu, select run, and type "dxdiag" in. Select the display tab and see what it says under Approx. Total Memory.

    Also, have you tried doing as it suggests? I can't recall whether 1.61 will wipe your .ini settings, but if it doesn't, you might try setting everything down to low detail in 1.09 and then installing the patch.

    Comment


    • #3
      Many thanks for your reply.

      The dxdiag tool is very useful.

      I had written down that the video card I was using was 64MB. However, dxdiag shows Approx Total Memory of 32MB. Asserting that the utiltity is probably more accurate (and apparently reliable) than my notes: ***there's my problem right there***

      The Min Sys Req's for the game (64MB).

      For some reason, the 1.09 is playable on my computer (I'm sliding by somehow). My guess is that the patch 1.61 requires more resources such that I can no longer slide-by with 32MB. Its interesting that it didn't pick up on my card's setting, but thats neither here nor there - my fooboo, not the game's.

      Solution: I'm going shopping, and will (quite happily) play v1.09 until I find a MinSysReq compliant card.

      Thanks again for your help

      Comment


      • #4
        No problem, glad you sorted things out. (Though it's always annoying when you need to upgrade specs... at least you have a desktop, it sounds like.)

        Comment


        • #5
          Approx. Total Memory n/a

          Hi there, trying to play several games in Windows 7 with Bootcamp. I.E. Medieval 2 and Civ 4, but no result so far. Have tried pretty much everything and looking at Can You Run It?, it must be a graphics issue, saying there's no Pixel Shader 1.0, Vertex Shader 1.0 or Video RAM.

          And checking the Approx. Total Memory in DirectX Diagnostic Tool it's n/a

          It all works perfectly on the OS X side, but very puzzled and no idea how to get my graphics working in Windows 7 32 bit.

          Comment


          • #6
            Select the display tab and see what it says under Approx.

            Comment


            • #7
              Originally posted by Kloreep View Post
              How much VRAM do you have? Go to the start menu, select run, and type "dxdiag" in. Select the display tab and see what it says under Approx. Total Memory.

              Also, have you tried doing as it suggests? I can't recall whether 1.61 will wipe your .ini settings, but if it doesn't, you might try setting everything down to low detail in 1.09 and then installing the patch.
              Is great.

              Comment


              • #8
                I think you should use win7 or win8

                Comment

                Working...
                X